CVE-2022-31016 Argo CD vulnerable to Uncontrolled Memory Consumption

Medium 6.5 Published Updated

An authenticated user can crash the Argo CD repo-server by deploying applications from a repository containing large files, causing a denial of service.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-31016?

CVE-2022-31016 is a medium-severity denial of service vulnerability in Argoproj Argo Cd, published on 25 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Argo CD is a declarative continuous deployment for Kubernetes. Argo CD versions v0.7.0 and later are vulnerable to an uncontrolled memory consumption bug, allowing an authorized malicious user to crash the repo-server service, resulting in a Denial of Service. The attacker must be an authenticated Argo CD user authorized to deploy Applications from a repository which contains (or can be made to contain) a large file. The fix for this vulnerability is available in versions 2.3.5, 2.2.10, 2.1.16, and later. There are no known workarounds. Users are recommended to upgrade.

Weakness: CWE-770, CWE-400

Which versions are affected by CVE-2022-31016?

12 open source packages ship an affected version, including github.com/argoproj/argo-cd/v2 and github.com/argoproj/argo-cd. It affects 1 product.

PackageAffectedFixed in
github.com/argoproj/argo-cd/v2 GoAll versions2.1.16, 2.2.10, 2.3.5, 2.4.1
github.com/argoproj/argo-cd/v2 GoAll versions2.1.16
github.com/argoproj/argo-cd/v2 GoAll versions2.1.16
github.com/argoproj/argo-cd/v2 GoFrom 2.2.02.2.10
github.com/argoproj/argo-cd/v2 GoFrom 2.2.02.2.10
github.com/argoproj/argo-cd/v2 GoFrom 2.3.02.3.5
6 more packages
github.com/argoproj/argo-cd/v2 GoFrom 2.3.02.3.5
github.com/argoproj/argo-cd/v2 GoFrom 2.4.02.4.1
github.com/argoproj/argo-cd/v2 GoFrom 2.4.02.4.1
github.com/argoproj/argo-cd GoFrom 0.7.0None
github.com/argoproj/argo-cd GoFrom 0.7.02.1.16
github.com/argoproj/argo-cd GoFrom 0.7.02.1.16

Products include Argoproj Argo Cd.

How do I fix CVE-2022-31016?

Upgrade github.com/argoproj/argo-cd/v2 to a fixed version for your release line: 2.1.16, 2.2.10, 2.3.5 or 2.4.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2022-31016 being exploited?

There is no known exploitation of CVE-2022-31016 in the wild and no public exploit code.

All Argoproj Argo Cd vulnerabilities

Sources

Also known as GHSA-jhqp-vf4w-rpwq, GO-2022-0495.

Is CVE-2022-31016 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free