CVE-2022-31017 Expression Always True vulnerability in Zulip Server

Low 2.0 Published Updated

Attackers can view private historical messages in protected streams by observing API events triggered by message edits.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2022-31017?

CVE-2022-31017 is a low-severity vulnerability in zulip, published on 25 Jun 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

Zulip is an open-source team collaboration tool. Versions 2.1.0 through and including 5.2 are vulnerable to a logic error. A stream configured as private with protected history, where new subscribers should not be allowed to see messages sent before they were subscribed, when edited causes the server to incorrectly send an API event that includes the edited message to all of the stream’s current subscribers. This API event is ignored by official clients, but can be observed by using a modified client or the browser’s developer tools. This bug will be fixed in Zulip Server 5.3. There are no known workarounds.

Weakness: CWE-670, CWE-571

Which versions are affected by CVE-2022-31017?

It affects 1 product.

Products include Zulip Zulip.

How do I fix CVE-2022-31017?

No fix has been published for CVE-2022-31017 yet. Limit exposure of the affected software until one is available.

Is CVE-2022-31017 being exploited?

There is no known exploitation of CVE-2022-31017 in the wild and no public exploit code.

Sources

Also known as GHSA-m5j3-jp59-6f3q.

Is CVE-2022-31017 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free