# CVE-2022-31017: Expression Always True vulnerability in Zulip Server

> Attackers can view private historical messages in protected streams by observing API events triggered by message edits.

- **Severity:** Low 2.0 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 25 Jun 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-m5j3-jp59-6f3q

## What is CVE-2022-31017?

CVE-2022-31017 is a low-severity vulnerability in zulip, published on 25 Jun 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Zulip is an open-source team collaboration tool. Versions 2.1.0 through and including 5.2 are vulnerable to a logic error. A stream configured as private with protected history, where new subscribers should not be allowed to see messages sent before they were subscribed, when edited causes the server to incorrectly send an API event that includes the edited message to all of the stream’s current subscribers. This API event is ignored by official clients, but can be observed by using a modified client or the browser’s developer tools. This bug will be fixed in Zulip Server 5.3. There are no known workarounds.

Weakness: CWE-670 (Always-Incorrect Control Flow Implementation), CWE-571 (Expression is Always True)

## Which versions are affected by CVE-2022-31017?

It affects 1 product.


Products: Zulip Zulip.

## How do I fix CVE-2022-31017?

No fix has been published for CVE-2022-31017 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-31017 being exploited?

There is no known exploitation of CVE-2022-31017 in the wild and no public exploit code.

## Other vulnerabilities in zulip

- [CVE-2021-43799](https://insights.sbomify.com/CVE-2021-43799/): RabbitMQ exposes ports with weak default secrets in Zulip Server (high 8.6)
- [CVE-2022-35962](https://insights.sbomify.com/CVE-2022-35962/): Crafted link in Zulip message can cause disclosure of credentials (high 8.0)
- [CVE-2016-4427](https://insights.sbomify.com/CVE-2016-4427/): Auth bypass in zulip (high 7.5)
- [CVE-2021-3866](https://insights.sbomify.com/CVE-2021-3866/): Cross-site Scripting (XSS) - Stored in zulip/zulip (medium 6.8)
- [CVE-2023-28623](https://insights.sbomify.com/CVE-2023-28623/): Unauthorized user can register an account in specific configurations in Zulip (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31017 and fix it if it is affected.

What it is: CVE-2022-31017 is a low-severity vulnerability in zulip, published on 25 Jun 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-31017 in the wild and no public exploit code.

Affected product: zulip. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31017/ (Markdown: https://insights.sbomify.com/CVE-2022-31017/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31017
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31017
- OSV: https://osv.dev/vulnerability/CVE-2022-31017

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31017/
Summaries are generated and may contain mistakes; the official description above is the record.
