CVE-2022-31018 Denial of service binding form from JSON in Play Framework
Attackers can crash Play Framework applications by sending deeply nested JSON data, causing an OutOfMemoryError and process termination.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-31018?
CVE-2022-31018 is a high-severity denial of service vulnerability in playframework, published on 2 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Play Framework is a web framework for Java and Scala. A denial of service vulnerability has been discovered in verions 2.8.3 through 2.8.15 of Play's forms library, in both the Scala and Java APIs. This can occur when using either the `Form#bindFromRequest` method on a JSON request body or the `Form#bind` method directly on a JSON value. If the JSON data being bound to the form contains a deeply-nested JSON object or array, the form binding implementation may consume all available heap space and cause an `OutOfMemoryError`. If executing on the default dispatcher and `akka.jvm-exit-on-fatal-error` is enabled—as it is by default—then this can crash the application process. `Form.bindFromRequest` is vulnerable when using any body parser that produces a type of `AnyContent` or `JsValue` in Scala, or one that can produce a `JsonNode` in Java. This includes Play's default body parser. This vulnerability been patched in version 2.8.16. There is now a global limit on the depth of a JSON object that can be parsed, which can be configured by the user if necessary. As a workaround, applications that do not need to parse a request body of type `application/json` can switch from the default body parser to another body parser that supports only the specific type of body they expect.
Weakness: CWE-400
Which versions are affected by CVE-2022-31018?
4 open source packages ship an affected version, including com.typesafe.play:play_2.12 and com.typesafe.play:play_2.13. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
com.typesafe.play:play_2.12 Maven | From 2.8.3 | 2.8.16 |
com.typesafe.play:play_2.12 Maven | From 2.8.3 | 2.8.16 |
com.typesafe.play:play_2.13 Maven | From 2.8.3 | 2.8.16 |
com.typesafe.play:play_2.13 Maven | From 2.8.3 | 2.8.16 |
Products include Lightbend Play Framework.
How do I fix CVE-2022-31018?
Upgrade com.typesafe.play:play_2.12 to 2.8.16 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2022-31018 being exploited?
There is no known exploitation of CVE-2022-31018 in the wild and no public exploit code.
Other vulnerabilities in playframework
Sources
Also known as GHSA-v8x6-59g4-5g3w.