# CVE-2022-31018: Denial of service binding form from JSON in Play Framework

> Attackers can crash Play Framework applications by sending deeply nested JSON data, causing an OutOfMemoryError and process termination.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jun 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-v8x6-59g4-5g3w

## What is CVE-2022-31018?

CVE-2022-31018 is a high-severity denial of service vulnerability in playframework, published on 2 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Play Framework is a web framework for Java and Scala. A denial of service vulnerability has been discovered in verions 2.8.3 through 2.8.15 of Play's forms library, in both the Scala and Java APIs. This can occur when using either the `Form#bindFromRequest` method on a JSON request body or the `Form#bind` method directly on a JSON value. If the JSON data being bound to the form contains a deeply-nested JSON object or array, the form binding implementation may consume all available heap space and cause an `OutOfMemoryError`. If executing on the default dispatcher and `akka.jvm-exit-on-fatal-error` is enabled—as it is by default—then this can crash the application process. `Form.bindFromRequest` is vulnerable when using any body parser that produces a type of `AnyContent` or `JsValue` in Scala, or one that can produce a `JsonNode` in Java. This includes Play's default body parser. This vulnerability been patched in version 2.8.16. There is now a global limit on the depth of a JSON object that can be parsed, which can be configured by the user if necessary. As a workaround, applications that do not need to parse a request body of type `application/json` can switch from the default body parser to another body parser that supports only the specific type of body they expect.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2022-31018?

4 open source packages ship an affected version, including com.typesafe.play:play_2.12 and com.typesafe.play:play_2.13. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.typesafe.play:play_2.12` | Maven | From 2.8.3 | 2.8.16 |
| `com.typesafe.play:play_2.12` | Maven | From 2.8.3 | 2.8.16 |
| `com.typesafe.play:play_2.13` | Maven | From 2.8.3 | 2.8.16 |
| `com.typesafe.play:play_2.13` | Maven | From 2.8.3 | 2.8.16 |

Products: Lightbend Play Framework.

## How do I fix CVE-2022-31018?

Upgrade com.typesafe.play:play_2.12 to 2.8.16 or later.

## Is CVE-2022-31018 being exploited?

There is no known exploitation of CVE-2022-31018 in the wild and no public exploit code.

## Other vulnerabilities in playframework

- [CVE-2014-3630](https://insights.sbomify.com/CVE-2014-3630/): XML external entity in n/a (critical 9.8)
- [CVE-2020-26882](https://insights.sbomify.com/CVE-2020-26882/): Data Amplification in Play Framework (high 7.5)
- [CVE-2020-26883](https://insights.sbomify.com/CVE-2020-26883/): Uncontrolled Recursion in Play Framework (high 7.5)
- [CVE-2020-27196](https://insights.sbomify.com/CVE-2020-27196/): Out-of-bounds Write in Play Framework (high 7.5)
- [CVE-2019-17598](https://insights.sbomify.com/CVE-2019-17598/): Play Framework Inadequate Encryption Strength vulnerability (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31018 and fix it if it is affected.

What it is: CVE-2022-31018 is a high-severity denial of service vulnerability in playframework, published on 2 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-31018 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.typesafe.play:play_2.12 (Maven): affected from 2.8.3; fixed in 2.8.16
- com.typesafe.play:play_2.12 (Maven): affected from 2.8.3; fixed in 2.8.16
- com.typesafe.play:play_2.13 (Maven): affected from 2.8.3; fixed in 2.8.16
- com.typesafe.play:play_2.13 (Maven): affected from 2.8.3; fixed in 2.8.16

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31018/ (Markdown: https://insights.sbomify.com/CVE-2022-31018/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31018
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31018
- OSV: https://osv.dev/vulnerability/CVE-2022-31018

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31018/
Summaries are generated and may contain mistakes; the official description above is the record.
