# CVE-2022-31019: DoS Vulnerability in URLEncodedFormDecoder in Vapor

> An attacker can crash the Vapor server by sending a crafted request with deeply nested array structures, causing a stack overflow.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jun 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-qvxg-wjxc-r4gg

## What is CVE-2022-31019?

CVE-2022-31019 is a high-severity denial of service vulnerability in vapor, published on 6 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vapor is a server-side Swift HTTP web framework. When using automatic content decoding an attacker can craft a request body that can make the server crash with the following request: `curl -d "array[_0][0][array][_0][0][array]$(for f in $(seq 1100); do echo -n '[_0][0][array]'; done)[string][_0]=hello%20world" http://localhost:8080/foo`. The issue is unbounded, attacker controlled stack growth which will at some point lead to a stack overflow and a process crash. This issue has been fixed in version 4.61.1.

Weakness: CWE-674 (Uncontrolled Recursion), CWE-120 (Buffer Copy without Checking Size of Input)

## Which versions are affected by CVE-2022-31019?

2 open source packages ship an affected version, including github.com/vapor/vapor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/vapor/vapor` | SwiftURL | All versions | 4.61.1 |
| `github.com/vapor/vapor` | SwiftURL | All versions | 4.61.1 |

Products: Vapor Vapor.

## How do I fix CVE-2022-31019?

Upgrade github.com/vapor/vapor to 4.61.1 or later.

## Is CVE-2022-31019 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31019 exists.

## Other vulnerabilities in vapor

- [CVE-2022-31005](https://insights.sbomify.com/CVE-2022-31005/): Integer Overflow in Vapor's HTTP Range Request (high 7.5)
- [CVE-2024-21631](https://insights.sbomify.com/CVE-2024-21631/): Integer overflow in URI leading to potential host spoofing (medium 6.5)
- [CVE-2023-44386](https://insights.sbomify.com/CVE-2023-44386/): Incorrect request error handling triggers server crash in Vapor (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31019 and fix it if it is affected.

What it is: CVE-2022-31019 is a high-severity denial of service vulnerability in vapor, published on 6 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31019 exists.

Affected packages and fixed versions:
- github.com/vapor/vapor (SwiftURL): affected all versions; fixed in 4.61.1
- github.com/vapor/vapor (SwiftURL): affected all versions; fixed in 4.61.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31019/ (Markdown: https://insights.sbomify.com/CVE-2022-31019/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31019
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31019
- OSV: https://osv.dev/vulnerability/CVE-2022-31019

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31019/
Summaries are generated and may contain mistakes; the official description above is the record.
