{"answers":{"affected":"3 open source packages ship an affected version, including indy-node. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-31020 in the wild and no public exploit code.","fix":"Upgrade indy-node to 1.12.5rc1 or later.","what":"CVE-2022-31020 is a high-severity code injection vulnerability in hyperledger indy-node, published on 6 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-31020 and fix it if it is affected.\n\nWhat it is: CVE-2022-31020 is a high-severity code injection vulnerability in hyperledger indy-node, published on 6 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-31020 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- indy-node (PyPI): affected all versions; fixed in 1.12.5rc1\n- indy-node (PyPI): affected all versions; fixed in 1.12.5rc1\n- indy-node (PyPI): affected all versions; fixed in 1.12.5rc1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-31020/ (Markdown: https://insights.sbomify.com/CVE-2022-31020/index.md)","id":"CVE-2022-31020","markdown":"https://insights.sbomify.com/CVE-2022-31020/index.md","name":"CVE-2022-31020","record":{"aliases":["GHSA-r6v9-p59m-gj2p","PYSEC-2022-265"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Indy Node server","requires_auth":"low_privilege","summary":"An improperly authenticated attacker can remotely execute code on Indy Node servers via the pool-upgrade transaction handler.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"indy-node","vendor":"linuxfoundation"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Indy Node is the server portion of a distributed ledger purpose-built for decentralized identity. In versions 1.12.4 and prior, the `pool-upgrade` request handler in Indy-Node allows an improperly authenticated attacker to remotely execute code on nodes within the network. The `pool-upgrade` request handler in Indy-Node 1.12.5 has been updated to properly authenticate pool-upgrade transactions before any processing is performed by the request handler. The transactions are further sanitized to prevent remote code execution. As a workaround, endorsers should not create DIDs for untrusted users. A vulnerable ledger should configure `auth_rules` to prevent new DIDs from being written to the ledger until the network can be upgraded.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Remote code execution in Indy's NODE_UPGRADE transaction","id":"CVE-2022-31020","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2022"},"n_packages":3,"n_references":3,"next":{"headline":"Unlinkability broken in ursa when verifiers use malicious keys","id":"CVE-2022-31021"},"packages":[{"ecosystem":"PyPI","fixed":["1.12.5rc1"],"introduced":["0"],"last_affected":[],"package":"indy-node","purl":null,"source":"GHSA-r6v9-p59m-gj2p"},{"ecosystem":"PyPI","fixed":["1.12.5rc1"],"introduced":["0"],"last_affected":[],"package":"indy-node","purl":"pkg:pypi/indy-node","source":"GHSA-r6v9-p59m-gj2p"},{"ecosystem":"PyPI","fixed":["1.12.5rc1"],"introduced":["0"],"last_affected":[],"package":"indy-node","purl":"pkg:pypi/indy-node","source":"PYSEC-2022-265"}],"prev":{"headline":"DoS Vulnerability in URLEncodedFormDecoder in Vapor","id":"CVE-2022-31019"},"products":["indy-node"],"published":"2022-09-06","related":[{"cvss_score":7.5,"headline":"Hyperledger Indy DOS vulnerability","id":"CVE-2022-31006","kev_date_added":null,"published":"2022-09-09"},{"cvss_score":7.5,"headline":"Authorization bypass in Hyperledger Indy","id":"CVE-2020-11093","kev_date_added":null,"published":"2020-12-24"},{"cvss_score":7.5,"headline":"Uncontrolled Resource Consumption in Indy Node","id":"CVE-2020-11090","kev_date_added":null,"published":"2020-06-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["hyperledger"]},"summary":"An improperly authenticated attacker can remotely execute code on Indy Node servers via the pool-upgrade transaction handler.","url":"https://insights.sbomify.com/CVE-2022-31020/"}