# CVE-2022-31020: Remote code execution in Indy's NODE_UPGRADE transaction

> An improperly authenticated attacker can remotely execute code on Indy Node servers via the pool-upgrade transaction handler.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Sep 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-r6v9-p59m-gj2p, PYSEC-2022-265

## What is CVE-2022-31020?

CVE-2022-31020 is a high-severity code injection vulnerability in hyperledger indy-node, published on 6 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Indy Node is the server portion of a distributed ledger purpose-built for decentralized identity. In versions 1.12.4 and prior, the `pool-upgrade` request handler in Indy-Node allows an improperly authenticated attacker to remotely execute code on nodes within the network. The `pool-upgrade` request handler in Indy-Node 1.12.5 has been updated to properly authenticate pool-upgrade transactions before any processing is performed by the request handler. The transactions are further sanitized to prevent remote code execution. As a workaround, endorsers should not create DIDs for untrusted users. A vulnerable ledger should configure `auth_rules` to prevent new DIDs from being written to the ledger until the network can be upgraded.

Weakness: CWE-287 (Improper Authentication), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2022-31020?

3 open source packages ship an affected version, including indy-node. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `indy-node` | PyPI | All versions | 1.12.5rc1 |
| `indy-node` | PyPI | All versions | 1.12.5rc1 |
| `indy-node` | PyPI | All versions | 1.12.5rc1 |

Products: Linuxfoundation Indy-Node.

## How do I fix CVE-2022-31020?

Upgrade indy-node to 1.12.5rc1 or later.

## Is CVE-2022-31020 being exploited?

There is no known exploitation of CVE-2022-31020 in the wild and no public exploit code.

## Other vulnerabilities in hyperledger indy-node

- [CVE-2022-31006](https://insights.sbomify.com/CVE-2022-31006/): Hyperledger Indy DOS vulnerability (high 7.5)
- [CVE-2020-11093](https://insights.sbomify.com/CVE-2020-11093/): Authorization bypass in Hyperledger Indy (high 7.5)
- [CVE-2020-11090](https://insights.sbomify.com/CVE-2020-11090/): Uncontrolled Resource Consumption in Indy Node (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31020 and fix it if it is affected.

What it is: CVE-2022-31020 is a high-severity code injection vulnerability in hyperledger indy-node, published on 6 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-31020 in the wild and no public exploit code.

Affected packages and fixed versions:
- indy-node (PyPI): affected all versions; fixed in 1.12.5rc1
- indy-node (PyPI): affected all versions; fixed in 1.12.5rc1
- indy-node (PyPI): affected all versions; fixed in 1.12.5rc1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31020/ (Markdown: https://insights.sbomify.com/CVE-2022-31020/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31020
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31020
- OSV: https://osv.dev/vulnerability/CVE-2022-31020

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31020/
Summaries are generated and may contain mistakes; the official description above is the record.
