CVE-2022-31023 Dev error stack trace leaking into prod in Play Framework
Attackers can view sensitive stack traces in production if developers inadvertently use the static DefaultHttpErrorHandler object instead of the injected instance.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-31023?
CVE-2022-31023 is a medium-severity vulnerability in playframework, published on 2 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Play Framework is a web framework for Java and Scala. Verions prior to 2.8.16 are vulnerable to generation of error messages containing sensitive information. Play Framework, when run in dev mode, shows verbose errors for easy debugging, including an exception stack trace. Play does this by configuring its `DefaultHttpErrorHandler` to do so based on the application mode. In its Scala API Play also provides a static object `DefaultHttpErrorHandler` that is configured to always show verbose errors. This is used as a default value in some Play APIs, so it is possible to inadvertently use this version in production. It is also possible to improperly configure the `DefaultHttpErrorHandler` object instance as the injected error handler. Both of these situations could result in verbose errors displaying to users in a production application, which could expose sensitive information from the application. In particular, the constructor for `CORSFilter` and `apply` method for `CORSActionBuilder` use the static object `DefaultHttpErrorHandler` as a default value. This is patched in Play Framework 2.8.16. The `DefaultHttpErrorHandler` object has been changed to use the prod-mode behavior, and `DevHttpErrorHandler` has been introduced for the dev-mode behavior. A workaround is available. When constructing a `CORSFilter` or `CORSActionBuilder`, ensure that a properly-configured error handler is passed. Generally this should be done by using the `HttpErrorHandler` instance provided through dependency injection or through Play's `BuiltInComponents`. Ensure that the application is not using the `DefaultHttpErrorHandler` static object in any code that may be run in production.
Weakness: CWE-209
Which versions are affected by CVE-2022-31023?
4 open source packages ship an affected version, including com.typesafe.play:play_2.12 and com.typesafe.play:play_2.13. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
com.typesafe.play:play_2.12 Maven | All versions | 2.8.16 |
com.typesafe.play:play_2.12 Maven | All versions | 2.8.16 |
com.typesafe.play:play_2.13 Maven | All versions | 2.8.16 |
com.typesafe.play:play_2.13 Maven | All versions | 2.8.16 |
Products include Lightbend Play Framework.
How do I fix CVE-2022-31023?
Upgrade com.typesafe.play:play_2.12 to 2.8.16 or later.
Is CVE-2022-31023 being exploited?
There is no known exploitation of CVE-2022-31023 in the wild and no public exploit code.
Other vulnerabilities in playframework
Sources
Also known as GHSA-p9p4-97g9-wcrh.