# CVE-2022-31023: Dev error stack trace leaking into prod in Play Framework

> Attackers can view sensitive stack traces in production if developers inadvertently use the static DefaultHttpErrorHandler object instead of the injected instance.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jun 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-p9p4-97g9-wcrh

## What is CVE-2022-31023?

CVE-2022-31023 is a medium-severity vulnerability in playframework, published on 2 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Play Framework is a web framework for Java and Scala. Verions prior to 2.8.16 are vulnerable to generation of error messages containing sensitive information. Play Framework, when run in dev mode, shows verbose errors for easy debugging, including an exception stack trace. Play does this by configuring its `DefaultHttpErrorHandler` to do so based on the application mode. In its Scala API Play also provides a static object `DefaultHttpErrorHandler` that is configured to always show verbose errors. This is used as a default value in some Play APIs, so it is possible to inadvertently use this version in production. It is also possible to improperly configure the `DefaultHttpErrorHandler` object instance as the injected error handler. Both of these situations could result in verbose errors displaying to users in a production application, which could expose sensitive information from the application. In particular, the constructor for `CORSFilter` and `apply` method for `CORSActionBuilder` use the static object `DefaultHttpErrorHandler` as a default value. This is patched in Play Framework 2.8.16. The `DefaultHttpErrorHandler` object has been changed to use the prod-mode behavior, and `DevHttpErrorHandler` has been introduced for the dev-mode behavior. A workaround is available. When constructing a `CORSFilter` or `CORSActionBuilder`, ensure that a properly-configured error handler is passed. Generally this should be done by using the `HttpErrorHandler` instance provided through dependency injection or through Play's `BuiltInComponents`. Ensure that the application is not using the `DefaultHttpErrorHandler` static object in any code that may be run in production.

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2022-31023?

4 open source packages ship an affected version, including com.typesafe.play:play_2.12 and com.typesafe.play:play_2.13. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.typesafe.play:play_2.12` | Maven | All versions | 2.8.16 |
| `com.typesafe.play:play_2.12` | Maven | All versions | 2.8.16 |
| `com.typesafe.play:play_2.13` | Maven | All versions | 2.8.16 |
| `com.typesafe.play:play_2.13` | Maven | All versions | 2.8.16 |

Products: Lightbend Play Framework.

## How do I fix CVE-2022-31023?

Upgrade com.typesafe.play:play_2.12 to 2.8.16 or later.

## Is CVE-2022-31023 being exploited?

There is no known exploitation of CVE-2022-31023 in the wild and no public exploit code.

## Other vulnerabilities in playframework

- [CVE-2014-3630](https://insights.sbomify.com/CVE-2014-3630/): XML external entity in n/a (critical 9.8)
- [CVE-2022-31018](https://insights.sbomify.com/CVE-2022-31018/): Denial of service binding form from JSON in Play Framework (high 7.5)
- [CVE-2020-26882](https://insights.sbomify.com/CVE-2020-26882/): Data Amplification in Play Framework (high 7.5)
- [CVE-2020-26883](https://insights.sbomify.com/CVE-2020-26883/): Uncontrolled Recursion in Play Framework (high 7.5)
- [CVE-2020-27196](https://insights.sbomify.com/CVE-2020-27196/): Out-of-bounds Write in Play Framework (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31023 and fix it if it is affected.

What it is: CVE-2022-31023 is a medium-severity vulnerability in playframework, published on 2 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-31023 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.typesafe.play:play_2.12 (Maven): affected all versions; fixed in 2.8.16
- com.typesafe.play:play_2.12 (Maven): affected all versions; fixed in 2.8.16
- com.typesafe.play:play_2.13 (Maven): affected all versions; fixed in 2.8.16
- com.typesafe.play:play_2.13 (Maven): affected all versions; fixed in 2.8.16

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31023/ (Markdown: https://insights.sbomify.com/CVE-2022-31023/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31023
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31023
- OSV: https://osv.dev/vulnerability/CVE-2022-31023

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31023/
Summaries are generated and may contain mistakes; the official description above is the record.
