# CVE-2022-31025: Invite bypasses user approval in Discourse

> Attackers can bypass user approval requirements on Discourse sites using single sign-on by exploiting invite mechanisms, potentially gaining unauthorized access.

- **Severity:** Low 2.6 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Jun 2022
- **Updated:** 23 Apr 2025
- **Also known as:** BIT-discourse-2022-31025, GHSA-x7jh-mx5q-6f9q

## What is CVE-2022-31025?

CVE-2022-31025 is a low-severity authentication bypass vulnerability in Discourse Discourse, published on 3 Jun 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Discourse is an open source platform for community discussion. Prior to version 2.8.4 on the `stable` branch and 2.9.0beta5 on the `beta` and `tests-passed` branches, inviting users on sites that use single sign-on could bypass the `must_approve_users` check and invites by staff are always approved automatically. The issue is patched in Discourse version 2.8.4 on the `stable` branch and version `2.9.0.beta5` on the `beta` and `tests-passed` branches. As a workaround, disable invites or increase `min_trust_level_to_allow_invite` to reduce the attack surface to more trusted users.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2022-31025?

1 open source package ship an affected version, including discourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 2.8.4 |

Products: Discourse Discourse.

## How do I fix CVE-2022-31025?

Upgrade discourse to 2.8.4 or later.

## Is CVE-2022-31025 being exploited?

There is no known exploitation of CVE-2022-31025 in the wild and no public exploit code.

## Other vulnerabilities in Discourse Discourse

- [CVE-2021-41163](https://insights.sbomify.com/CVE-2021-41163/): RCE via malicious SNS subscription payload (critical 10.0)
- [CVE-2022-36066](https://insights.sbomify.com/CVE-2022-36066/): Discourse vulnerable to RCE via admins uploading maliciously zipped file (critical 9.1)
- [CVE-2022-39356](https://insights.sbomify.com/CVE-2022-39356/): Discourse user account takeover via email and invite link (high 8.9)
- [CVE-2023-22468](https://insights.sbomify.com/CVE-2023-22468/): Discourse vulnerable to Cross-site Scripting in local oneboxes (high 8.8)
- [CVE-2026-27934](https://insights.sbomify.com/CVE-2026-27934/): Discourse leaks private topic title and post excerpt via user action API endpoint (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31025 and fix it if it is affected.

What it is: CVE-2022-31025 is a low-severity authentication bypass vulnerability in Discourse Discourse, published on 3 Jun 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-31025 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 2.8.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31025/ (Markdown: https://insights.sbomify.com/CVE-2022-31025/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31025
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31025
- OSV: https://osv.dev/vulnerability/CVE-2022-31025

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31025/
Summaries are generated and may contain mistakes; the official description above is the record.
