# CVE-2022-31027: Authorization Bypass Through User-Controlled Key when using CILogonOAuthenticator in oauthenticator

> Attackers can bypass institutional access restrictions in JupyterHub by spoofing email domains via external OAuth providers like GitHub.

- **Severity:** Medium 4.2 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jun 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-r7v4-jwx9-wx43, PYSEC-2022-206

## What is CVE-2022-31027?

CVE-2022-31027 is a medium-severity authentication bypass vulnerability in jupyterhub oauthenticator, published on 6 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OAuthenticator is an OAuth token library for the JupyerHub login handler. CILogonOAuthenticator is provided by the OAuthenticator package, and lets users log in to a JupyterHub via CILogon. This is primarily used to restrict a JupyterHub only to users of a given institute. The allowed_idps configuration trait of CILogonOAuthenticator is documented to be a list of domains that indicate the institutions whose users are authorized to access this JupyterHub. This authorization is validated by ensuring that the *email* field provided to us by CILogon has a *domain* that matches one of the domains listed in `allowed_idps`.If `allowed_idps` contains `berkeley.edu`, you might expect only users with valid current credentials provided by University of California, Berkeley to be able to access the JupyterHub. However, CILogonOAuthenticator does *not* verify which provider is used by the user to login, only the email address provided. So a user can login with a GitHub account that has email set to `<something>@berkeley.edu`, and that will be treated exactly the same as someone logging in using the UC Berkeley official Identity Provider. The patch fixing this issue makes a *breaking change* in how `allowed_idps` is interpreted. It's no longer a list of domains, but configuration representing the `EntityID` of the IdPs that are allowed, picked from the [list maintained by CILogon](https://cilogon.org/idplist/). Users are advised to upgrade.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2022-31027?

3 open source packages ship an affected version, including oauthenticator. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `oauthenticator` | PyPI | All versions | 15.0.0 |
| `oauthenticator` | PyPI | All versions | 15.0.0 |
| `oauthenticator` | PyPI | All versions | 15.0.0 |

Products: Jupyter Oauthenticator.

## How do I fix CVE-2022-31027?

Upgrade oauthenticator to 15.0.0 or later.

## Is CVE-2022-31027 being exploited?

There is no known exploitation of CVE-2022-31027 in the wild and no public exploit code.

## Other vulnerabilities in jupyterhub oauthenticator

- [CVE-2026-33175](https://insights.sbomify.com/CVE-2026-33175/): OAuthenticator: Authentication Bypass in Auth0OAuthenticator via Unverified Email Claims (high 8.8)
- [CVE-2018-7206](https://insights.sbomify.com/CVE-2018-7206/): JupyterHub OAuthenticator elevation of privilege (high 8.8)
- [CVE-2024-29033](https://insights.sbomify.com/CVE-2024-29033/): GoogleOAuthenticator.hosted_domain incorrectly verifies membership of an Google organization/workspace (high 7.5)
- [CVE-2020-26250](https://insights.sbomify.com/CVE-2020-26250/): Base class whitelist configuration ignored in OAuthenticator (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31027 and fix it if it is affected.

What it is: CVE-2022-31027 is a medium-severity authentication bypass vulnerability in jupyterhub oauthenticator, published on 6 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-31027 in the wild and no public exploit code.

Affected packages and fixed versions:
- oauthenticator (PyPI): affected all versions; fixed in 15.0.0
- oauthenticator (PyPI): affected all versions; fixed in 15.0.0
- oauthenticator (PyPI): affected all versions; fixed in 15.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31027/ (Markdown: https://insights.sbomify.com/CVE-2022-31027/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31027
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31027
- OSV: https://osv.dev/vulnerability/CVE-2022-31027

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31027/
Summaries are generated and may contain mistakes; the official description above is the record.
