{"answers":{"affected":"2 open source packages ship an affected version, including oro/commerce. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-31037 in the wild and no public exploit code.","fix":"Upgrade oro/commerce to 5.0.6 or later.","what":"CVE-2022-31037 is a medium-severity cross-site scripting vulnerability in oroinc orocommerce, published on 18 Oct 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-31037 and fix it if it is affected.\n\nWhat it is: CVE-2022-31037 is a medium-severity cross-site scripting vulnerability in oroinc orocommerce, published on 18 Oct 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-31037 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- oro/commerce (Packagist): affected from 4.1.0; fixed in 5.0.6\n- oro/commerce (Packagist): affected from 4.1.0; fixed in 5.0.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-31037/ (Markdown: https://insights.sbomify.com/CVE-2022-31037/index.md)","id":"CVE-2022-31037","markdown":"https://insights.sbomify.com/CVE-2022-31037/index.md","name":"CVE-2022-31037","record":{"aliases":["GHSA-4vf4-955g-vxp2"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"OroCommerce e-commerce","requires_auth":"high_privilege","summary":"An attacker with shipping rule editing permissions can inject malicious scripts via the UPS Surcharge field, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"orocommerce","vendor":"oroinc"}],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"OroCommerce is an open-source Business to Business Commerce application. Versions between 4.1.0 and 4.1.17 inclusive, 4.2.0 and 4.2.11 inclusive, and between 5.0.0 and 5.0.3 inclusive, are vulnerable to Cross-site Scripting in the UPS Surcharge field of the Shipping rule edit page. The attacker needs permission to create or edit a shipping rule. This issue has been patched in version 5.0.6. There are no known workarounds.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OroCommerce vulnerable to Cross-site Scripting via Shipping rule editing page","id":"CVE-2022-31037","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":2,"n_references":1,"next":{"headline":"XSS vulnerability in repository issue list in Gogs","id":"CVE-2022-31038"},"packages":[{"ecosystem":"Packagist","fixed":["5.0.6"],"introduced":["4.1.0"],"last_affected":[],"package":"oro/commerce","purl":null,"source":"GHSA-4vf4-955g-vxp2"},{"ecosystem":"Packagist","fixed":["5.0.6"],"introduced":["4.1.0"],"last_affected":[],"package":"oro/commerce","purl":"pkg:composer/oro/commerce","source":"GHSA-4vf4-955g-vxp2"}],"prev":{"headline":"Symlink following allows leaking out-of-bounds YAML files from Argo CD repo-server","id":"CVE-2022-31036"},"products":["orocommerce"],"published":"2022-10-18","related":[{"cvss_score":6.9,"headline":"OroCommerce Cross-site Scripting vulnerability in add note dialog of Shopping List line item","id":"CVE-2022-35950","kev_date_added":null,"published":"2023-10-09"},{"cvss_score":5.8,"headline":"OroCommerce get-totals-for-checkout API endpoint returns unwanted data","id":"CVE-2023-32065","kev_date_added":null,"published":"2023-11-28"},{"cvss_score":5,"headline":"OroCommerce Customer Portal Incorrect Customer and Customer Group Frontend Menus pages visibility","id":"CVE-2023-32064","kev_date_added":null,"published":"2023-11-28"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["oroinc"]},"summary":"An attacker with shipping rule editing permissions can inject malicious scripts via the UPS Surcharge field, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2022-31037/"}