# CVE-2022-31037: OroCommerce vulnerable to Cross-site Scripting via Shipping rule editing page

> An attacker with shipping rule editing permissions can inject malicious scripts via the UPS Surcharge field, potentially compromising user sessions.

- **Severity:** Medium 6.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Oct 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-4vf4-955g-vxp2

## What is CVE-2022-31037?

CVE-2022-31037 is a medium-severity cross-site scripting vulnerability in oroinc orocommerce, published on 18 Oct 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

OroCommerce is an open-source Business to Business Commerce application. Versions between 4.1.0 and 4.1.17 inclusive, 4.2.0 and 4.2.11 inclusive, and between 5.0.0 and 5.0.3 inclusive, are vulnerable to Cross-site Scripting in the UPS Surcharge field of the Shipping rule edit page. The attacker needs permission to create or edit a shipping rule. This issue has been patched in version 5.0.6. There are no known workarounds.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-31037?

2 open source packages ship an affected version, including oro/commerce. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `oro/commerce` | Packagist | From 4.1.0 | 5.0.6 |
| `oro/commerce` | Packagist | From 4.1.0 | 5.0.6 |

Products: Oroinc Orocommerce.

## How do I fix CVE-2022-31037?

Upgrade oro/commerce to 5.0.6 or later.

## Is CVE-2022-31037 being exploited?

There is no known exploitation of CVE-2022-31037 in the wild and no public exploit code.

## Other vulnerabilities in oroinc orocommerce

- [CVE-2022-35950](https://insights.sbomify.com/CVE-2022-35950/): OroCommerce Cross-site Scripting vulnerability in add note dialog of Shopping List line item (medium 6.9)
- [CVE-2023-32065](https://insights.sbomify.com/CVE-2023-32065/): OroCommerce get-totals-for-checkout API endpoint returns unwanted data (medium 5.8)
- [CVE-2023-32064](https://insights.sbomify.com/CVE-2023-32064/): OroCommerce Customer Portal Incorrect Customer and Customer Group Frontend Menus pages visibility (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31037 and fix it if it is affected.

What it is: CVE-2022-31037 is a medium-severity cross-site scripting vulnerability in oroinc orocommerce, published on 18 Oct 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-31037 in the wild and no public exploit code.

Affected packages and fixed versions:
- oro/commerce (Packagist): affected from 4.1.0; fixed in 5.0.6
- oro/commerce (Packagist): affected from 4.1.0; fixed in 5.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31037/ (Markdown: https://insights.sbomify.com/CVE-2022-31037/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31037
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31037
- OSV: https://osv.dev/vulnerability/CVE-2022-31037

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31037/
Summaries are generated and may contain mistakes; the official description above is the record.
