# CVE-2022-31038: XSS vulnerability in repository issue list in Gogs

> Attackers can inject malicious scripts via user display names in the issue list, potentially leading to code execution or account takeover.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Jun 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-xq4v-vrp9-vcf2, GO-2022-0483

## What is CVE-2022-31038?

CVE-2022-31038 is a medium-severity cross-site scripting vulnerability in gogs, published on 8 Jun 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Gogs is an open source self-hosted Git service. In versions of gogs prior to 0.12.9 `DisplayName` does not filter characters input from users, which leads to an XSS vulnerability when directly displayed in the issue list. This issue has been resolved in commit 155cae1d which sanitizes `DisplayName` prior to display to the user. All users of gogs are advised to upgrade. Users unable to upgrade should check their users' display names for malicious characters.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-31038?

3 open source packages ship an affected version, including gogs.io/gogs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gogs.io/gogs` | Go | All versions | 0.12.9 |
| `gogs.io/gogs` | Go | All versions | 0.12.9 |
| `gogs.io/gogs` | Go | All versions | 0.12.9 |

Products: Gogs Gogs.

## How do I fix CVE-2022-31038?

Upgrade gogs.io/gogs to 0.12.9 or later.

## Is CVE-2022-31038 being exploited?

There is no known exploitation of CVE-2022-31038 in the wild and no public exploit code.

## Other vulnerabilities in gogs

- [CVE-2025-8110](https://insights.sbomify.com/CVE-2025-8110/): Gogs Path Traversal (high 8.7, exploited in the wild)
- [CVE-2024-56731](https://insights.sbomify.com/CVE-2024-56731/): Gogs deletion of internal files allows remote command execution (critical 10.0)
- [CVE-2022-1884](https://insights.sbomify.com/CVE-2022-1884/): Remote Command Execution in gogs/gogs (critical 10.0)
- [CVE-2022-1986](https://insights.sbomify.com/CVE-2022-1986/): OS Command Injection in gogs/gogs (critical 10.0)
- [CVE-2022-1992](https://insights.sbomify.com/CVE-2022-1992/): Path Traversal in gogs/gogs (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31038 and fix it if it is affected.

What it is: CVE-2022-31038 is a medium-severity cross-site scripting vulnerability in gogs, published on 8 Jun 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-31038 in the wild and no public exploit code.

Affected packages and fixed versions:
- gogs.io/gogs (Go): affected all versions; fixed in 0.12.9
- gogs.io/gogs (Go): affected all versions; fixed in 0.12.9
- gogs.io/gogs (Go): affected all versions; fixed in 0.12.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31038/ (Markdown: https://insights.sbomify.com/CVE-2022-31038/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31038
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31038
- OSV: https://osv.dev/vulnerability/CVE-2022-31038

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31038/
Summaries are generated and may contain mistakes; the official description above is the record.
