CVE-2022-31044 Plaintext Storage of Keys and Passwords in Rundeck and PagerDuty Process Automation

High 7.5 Published Updated

Attackers with backend access can read plaintext credentials stored by Rundeck due to a broken encryption plugin mechanism in specific versions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-31044?

CVE-2022-31044 is a high-severity vulnerability in rundeck, published on 15 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Rundeck is an open source automation service with a web console, command line tools and a WebAPI. The Key Storage converter plugin mechanism was not enabled correctly in Rundeck 4.2.0 and 4.2.1, resulting in use of the encryption layer for Key Storage possibly not working. Any credentials created or overwritten using Rundeck 4.2.0 or 4.2.1 might result in them being written in plaintext to the backend storage. This affects those using any `Storage Converter` plugin. Rundeck 4.3.1 and 4.2.2 have fixed the code and upon upgrade will re-encrypt any plain text values. Version 4.3.0 does not have the vulnerability, but does not include the patch to re-encrypt plain text values if 4.2.0 or 4.2.1 were used. To prevent plaintext credentials from being stored in Rundeck 4.2.0/4.2.1, write access to key storage can be disabled via ACLs. After upgrading to 4.3.1 or later, write access can be restored.

Weakness: CWE-522, CWE-256

Which versions are affected by CVE-2022-31044?

4 open source packages ship an affected version, including org.rundeck:rundeck. It affects 1 product.

PackageAffectedFixed in
org.rundeck:rundeck MavenFrom 4.2.04.2.2
org.rundeck:rundeck MavenFrom 4.2.04.2.2
org.rundeck:rundeck MavenFrom 4.3.04.3.1
org.rundeck:rundeck MavenFrom 4.3.04.3.1

Products include Pagerduty Rundeck.

How do I fix CVE-2022-31044?

Upgrade org.rundeck:rundeck to a fixed version for your release line: 4.2.2 or 4.3.1.

Is CVE-2022-31044 being exploited?

There is no known exploitation of CVE-2022-31044 in the wild and no public exploit code.

Sources

Also known as GHSA-hprf-rrwq-jm5c.

Is CVE-2022-31044 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free