# CVE-2022-31044: Plaintext Storage of Keys and Passwords in Rundeck and PagerDuty Process Automation

> Attackers with backend access can read plaintext credentials stored by Rundeck due to a broken encryption plugin mechanism in specific versions.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jun 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-hprf-rrwq-jm5c

## What is CVE-2022-31044?

CVE-2022-31044 is a high-severity vulnerability in rundeck, published on 15 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Rundeck is an open source automation service with a web console, command line tools and a WebAPI. The Key Storage converter plugin mechanism was not enabled correctly in Rundeck 4.2.0 and 4.2.1, resulting in use of the encryption layer for Key Storage possibly not working. Any credentials created or overwritten using Rundeck 4.2.0 or 4.2.1 might result in them being written in plaintext to the backend storage. This affects those using any `Storage Converter` plugin. Rundeck 4.3.1 and 4.2.2 have fixed the code and upon upgrade will re-encrypt any plain text values. Version 4.3.0 does not have the vulnerability, but does not include the patch to re-encrypt plain text values if 4.2.0 or 4.2.1 were used. To prevent plaintext credentials from being stored in Rundeck 4.2.0/4.2.1, write access to key storage can be disabled via ACLs. After upgrading to 4.3.1 or later, write access can be restored.

Weakness: CWE-522 (Insufficiently Protected Credentials), CWE-256 (Plaintext Storage of a Password)

## Which versions are affected by CVE-2022-31044?

4 open source packages ship an affected version, including org.rundeck:rundeck. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.rundeck:rundeck` | Maven | From 4.2.0 | 4.2.2 |
| `org.rundeck:rundeck` | Maven | From 4.2.0 | 4.2.2 |
| `org.rundeck:rundeck` | Maven | From 4.3.0 | 4.3.1 |
| `org.rundeck:rundeck` | Maven | From 4.3.0 | 4.3.1 |

Products: Pagerduty Rundeck.

## How do I fix CVE-2022-31044?

Upgrade org.rundeck:rundeck to a fixed version for your release line: 4.2.2 or 4.3.1.

## Is CVE-2022-31044 being exploited?

There is no known exploitation of CVE-2022-31044 in the wild and no public exploit code.

## Other vulnerabilities in rundeck

- [CVE-2022-29186](https://insights.sbomify.com/CVE-2022-29186/): Use of Hard-coded Cryptographic Key in rundeck/rundeck, rundeckpro/enterprise (critical 9.1)
- [CVE-2021-39132](https://insights.sbomify.com/CVE-2021-39132/): YAML deserialization can run untrusted code (high 8.8)
- [CVE-2023-48222](https://insights.sbomify.com/CVE-2023-48222/): Authenticated users can view or delete jobs they do not have authorization for in Rundeck (high 8.1)
- [CVE-2021-41112](https://insights.sbomify.com/CVE-2021-41112/): Missing Authorization in Rundeck (high 8.1)
- [CVE-2021-39133](https://insights.sbomify.com/CVE-2021-39133/): Cross-Site Request Forgery (CSRF) can run untrusted code on Rundeck server (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31044 and fix it if it is affected.

What it is: CVE-2022-31044 is a high-severity vulnerability in rundeck, published on 15 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-31044 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.rundeck:rundeck (Maven): affected from 4.2.0; fixed in 4.2.2
- org.rundeck:rundeck (Maven): affected from 4.2.0; fixed in 4.2.2
- org.rundeck:rundeck (Maven): affected from 4.3.0; fixed in 4.3.1
- org.rundeck:rundeck (Maven): affected from 4.3.0; fixed in 4.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31044/ (Markdown: https://insights.sbomify.com/CVE-2022-31044/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31044
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31044
- OSV: https://osv.dev/vulnerability/CVE-2022-31044

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31044/
Summaries are generated and may contain mistakes; the official description above is the record.
