# CVE-2022-31047: Insertion of Sensitive Information into Log File in typo3/cms-core

> Attackers with log access can read sensitive system credentials like database keys exposed in plaintext exception logs.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jun 2022
- **Updated:** 23 Apr 2025
- **Also known as:** BIT-typo3-2022-31047, GHSA-fh99-4pgr-8j99

## What is CVE-2022-31047?

CVE-2022-31047 is a medium-severity vulnerability in Typo3 Typo3, published on 14 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

TYPO3 is an open source web content management system. Prior to versions 7.6.57 ELTS, 8.7.47 ELTS, 9.5.34 ELTS, 10.4.29, and 11.5.11, system internal credentials or keys (e.g. database credentials) can be logged as plaintext in exception handlers, when logging the complete exception stack trace. TYPO3 versions 7.6.57 ELTS, 8.7.47 ELTS, 9.5.34 ELTS, 10.4.29, 11.5.11 contain a fix for the problem.

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information), CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2022-31047?

15 open source packages ship an affected version, including typo3/cms-core, typo3 and typo3/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `typo3/cms-core` | Packagist | From 10.0.0 | 10.4.29 |
| `typo3/cms-core` | Packagist | From 10.0.0 | 10.4.29 |
| `typo3/cms-core` | Packagist | From 11.0.0 | 11.5.11 |
| `typo3/cms-core` | Packagist | From 11.0.0 | 11.5.11 |
| `typo3/cms-core` | Packagist | From 7.0.0 | 7.6.57 |
| `typo3/cms-core` | Packagist | From 7.0.0 | 7.6.57 |
| `typo3/cms-core` | Packagist | From 8.0.0 | 8.7.47 |
| `typo3/cms-core` | Packagist | From 8.0.0 | 8.7.47 |
| `typo3/cms-core` | Packagist | From 9.0.0 | 9.5.35 |
| `typo3/cms-core` | Packagist | From 9.0.0 | 9.5.35 |
| `typo3` | Bitnami | From 7.0.0 | 7.6.57, 8.7.47, 9.5.35, 10.4.29, 11.5.11 |
| `typo3/cms` | Packagist | From 10.0.0 | 10.4.29 |
| `typo3/cms` | Packagist | From 10.0.0 | 10.4.29 |
| `typo3/cms` | Packagist | From 11.0.0 | 11.5.11 |
| `typo3/cms` | Packagist | From 11.0.0 | 11.5.11 |

Products: Typo3 Typo3.

## How do I fix CVE-2022-31047?

Upgrade typo3/cms-core to a fixed version for your release line: 10.4.29, 11.5.11, 7.6.57 or 8.7.47.

## Is CVE-2022-31047 being exploited?

There is no known exploitation of CVE-2022-31047 in the wild and no public exploit code.

## Other vulnerabilities in Typo3 Typo3

- [CVE-2009-0258](https://insights.sbomify.com/CVE-2009-0258/): Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection (critical 10.0)
- [CVE-2011-3583](https://insights.sbomify.com/CVE-2011-3583/): Typo3 SQL injection due to faulty prepared statements (critical 9.8)
- [CVE-2011-4628](https://insights.sbomify.com/CVE-2011-4628/): Typo3 Authentication Bypass (critical 9.8)
- [CVE-2023-24814](https://insights.sbomify.com/CVE-2023-24814/): Persisted Cross-Site Scripting in Frontend Rendering in typo3 (high 8.8)
- [CVE-2021-41113](https://insights.sbomify.com/CVE-2021-41113/): Cross-Site-Request-Forgery in Backend URI Handling in Typo3 (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31047 and fix it if it is affected.

What it is: CVE-2022-31047 is a medium-severity vulnerability in Typo3 Typo3, published on 14 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-31047 in the wild and no public exploit code.

Affected packages and fixed versions:
- typo3/cms-core (Packagist): affected from 10.0.0; fixed in 10.4.29
- typo3/cms-core (Packagist): affected from 10.0.0; fixed in 10.4.29
- typo3/cms-core (Packagist): affected from 11.0.0; fixed in 11.5.11
- typo3/cms-core (Packagist): affected from 11.0.0; fixed in 11.5.11
- typo3/cms-core (Packagist): affected from 7.0.0; fixed in 7.6.57
- typo3/cms-core (Packagist): affected from 7.0.0; fixed in 7.6.57
- typo3/cms-core (Packagist): affected from 8.0.0; fixed in 8.7.47
- typo3/cms-core (Packagist): affected from 8.0.0; fixed in 8.7.47
- typo3/cms-core (Packagist): affected from 9.0.0; fixed in 9.5.35
- typo3/cms-core (Packagist): affected from 9.0.0; fixed in 9.5.35
- typo3 (Bitnami): affected from 7.0.0; fixed in 7.6.57, 8.7.47, 9.5.35, 10.4.29, 11.5.11
- typo3/cms (Packagist): affected from 10.0.0; fixed in 10.4.29

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31047/ (Markdown: https://insights.sbomify.com/CVE-2022-31047/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31047
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31047
- OSV: https://osv.dev/vulnerability/CVE-2022-31047

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31047/
Summaries are generated and may contain mistakes; the official description above is the record.
