CVE-2022-31048 Cross-Site Scripting in Form Framework

Medium 5.4 Published Updated

An authenticated backend user can execute arbitrary scripts via the Form Designer module, potentially compromising other users or the system.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-31048?

CVE-2022-31048 is a medium-severity cross-site scripting vulnerability in Typo3 Typo3, published on 14 Jun 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

TYPO3 is an open source web content management system. Prior to versions 8.7.47 ELTS, 9.5.34 ELTS, 10.4.29, and 11.5.11, the Form Designer backend module of the Form Framework is vulnerable to cross-site scripting. A valid backend user account with access to the form module is needed to exploit this vulnerability. TYPO3 versions 8.7.47 ELTS, 9.5.34 ELTS, 10.4.29, and 11.5.11 contain a fix for the problem.

Weakness: CWE-79

Which versions are affected by CVE-2022-31048?

13 open source packages ship an affected version, including typo3/cms-core, typo3 and typo3/cms. It affects 1 product.

PackageAffectedFixed in
typo3/cms-core PackagistFrom 10.0.010.4.29
typo3/cms-core PackagistFrom 10.0.010.4.29
typo3/cms-core PackagistFrom 11.0.011.5.11
typo3/cms-core PackagistFrom 11.0.011.5.11
typo3/cms-core PackagistFrom 8.0.08.7.47
typo3/cms-core PackagistFrom 8.0.08.7.47
7 more packages
typo3/cms-core PackagistFrom 9.0.09.5.35
typo3/cms-core PackagistFrom 9.0.09.5.35
typo3 BitnamiFrom 8.0.08.7.47, 9.5.35, 10.4.29, 11.5.11
typo3/cms PackagistFrom 10.0.010.4.29
typo3/cms PackagistFrom 10.0.010.4.29
typo3/cms PackagistFrom 11.0.011.5.11
typo3/cms PackagistFrom 11.0.011.5.11

Products include Typo3 Typo3.

How do I fix CVE-2022-31048?

Upgrade typo3/cms-core to a fixed version for your release line: 10.4.29, 11.5.11, 8.7.47 or 9.5.35.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2022-31048 being exploited?

There is no known exploitation of CVE-2022-31048 in the wild and no public exploit code.

All Typo3 Typo3 vulnerabilities

Sources

Also known as BIT-typo3-2022-31048, GHSA-3r95-23jp-mhvg.

Is CVE-2022-31048 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free