CVE-2022-31049 Cross-Site Scripting in Frontend Login Mailer
Attackers can inject malicious scripts into HTML emails sent by TYPO3, potentially compromising users who view these messages in vulnerable mail clients.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-31049?
CVE-2022-31049 is a medium-severity cross-site scripting vulnerability in Typo3 Typo3, published on 14 Jun 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
TYPO3 is an open source web content management system. Prior to versions 9.5.34 ELTS, 10.4.29, and 11.5.11, user submitted content was used without being properly encoded in HTML emails sent to users. The actually affected components were mail clients used to view those messages. TYPO3 versions 9.5.34 ELTS, 10.4.29, and 11.5.11 contain a fix for the problem.
Weakness: CWE-79
Which versions are affected by CVE-2022-31049?
11 open source packages ship an affected version, including typo3/cms-core, typo3 and typo3/cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
typo3/cms-core Packagist | From 10.0.0 | 10.4.29 |
typo3/cms-core Packagist | From 10.0.0 | 10.4.29 |
typo3/cms-core Packagist | From 11.0.0 | 11.5.11 |
typo3/cms-core Packagist | From 11.0.0 | 11.5.11 |
typo3/cms-core Packagist | From 9.0.0 | 9.5.35 |
typo3/cms-core Packagist | From 9.0.0 | 9.5.35 |
5 more packages
typo3 Bitnami | From 9.0.0 | 9.5.35, 10.4.29, 11.5.11 |
typo3/cms Packagist | From 10.0.0 | 10.4.29 |
typo3/cms Packagist | From 10.0.0 | 10.4.29 |
typo3/cms Packagist | From 11.0.0 | 11.5.11 |
typo3/cms Packagist | From 11.0.0 | 11.5.11 |
Products include Typo3 Typo3.
How do I fix CVE-2022-31049?
Upgrade typo3/cms-core to a fixed version for your release line: 10.4.29, 11.5.11 or 9.5.35.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2022-31049 being exploited?
There is no known exploitation of CVE-2022-31049 in the wild and no public exploit code.
Other vulnerabilities in Typo3 Typo3
- CVE-2009-0258 Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection
- CVE-2011-3583 Typo3 SQL injection due to faulty prepared statements
- CVE-2011-4628 Typo3 Authentication Bypass
- CVE-2023-24814 Persisted Cross-Site Scripting in Frontend Rendering in typo3
- CVE-2021-41113 Cross-Site-Request-Forgery in Backend URI Handling in Typo3
Sources
Also known as BIT-typo3-2022-31049, GHSA-h4mx-xv96-2jgm.