CVE-2022-31050 Insufficient Session Expiration in TYPO3 Admin Tool
Attackers can retain admin tool access after account deactivation or permission reduction due to insufficient session expiration in TYPO3.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-31050?
CVE-2022-31050 is a medium-severity authentication bypass vulnerability in Typo3 Typo3, published on 14 Jun 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
TYPO3 is an open source web content management system. Prior to versions 9.5.34 ELTS, 10.4.29, and 11.5.11, Admin Tool sessions initiated via the TYPO3 backend user interface had not been revoked even if the corresponding user account was degraded to lower permissions or disabled completely. This way, sessions in the admin tool theoretically could have been prolonged without any limit. TYPO3 versions 9.5.34 ELTS, 10.4.29, and 11.5.11 contain a fix for the problem.
Weakness: CWE-613
Which versions are affected by CVE-2022-31050?
11 open source packages ship an affected version, including typo3/cms-core, typo3 and typo3/cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
typo3/cms-core Packagist | From 10.0.0 | 10.4.29 |
typo3/cms-core Packagist | From 10.0.0 | 10.4.29 |
typo3/cms-core Packagist | From 11.0.0 | 11.5.11 |
typo3/cms-core Packagist | From 11.0.0 | 11.5.11 |
typo3/cms-core Packagist | From 9.0.0 | 9.5.35 |
typo3/cms-core Packagist | From 9.0.0 | 9.5.35 |
5 more packages
typo3 Bitnami | From 9.0.0 | 9.5.35, 10.4.29, 11.5.11 |
typo3/cms Packagist | From 10.0.0 | 10.4.29 |
typo3/cms Packagist | From 10.0.0 | 10.4.29 |
typo3/cms Packagist | From 11.0.0 | 11.5.11 |
typo3/cms Packagist | From 11.0.0 | 11.5.11 |
Products include Typo3 Typo3.
How do I fix CVE-2022-31050?
Upgrade typo3/cms-core to a fixed version for your release line: 10.4.29, 11.5.11 or 9.5.35.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2022-31050 being exploited?
There is no known exploitation of CVE-2022-31050 in the wild and no public exploit code.
Other vulnerabilities in Typo3 Typo3
- CVE-2009-0258 Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection
- CVE-2011-3583 Typo3 SQL injection due to faulty prepared statements
- CVE-2011-4628 Typo3 Authentication Bypass
- CVE-2023-24814 Persisted Cross-Site Scripting in Frontend Rendering in typo3
- CVE-2021-41113 Cross-Site-Request-Forgery in Backend URI Handling in Typo3
Sources
Also known as BIT-typo3-2022-31050, GHSA-wwjw-r3gj-39fq.