CVE-2022-31052 URL previews can crash Synapse media repositories or Synapse monoliths

Medium 6.5 Published Updated

Authenticated users can crash Synapse servers via unbounded recursion in URL previews, requiring administrators to upgrade or disable the feature.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-31052?

CVE-2022-31052 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 28 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Synapse is an open source home server implementation for the Matrix chat network. In versions prior to 1.61.1 URL previews of some web pages can exhaust the available stack space for the Synapse process due to unbounded recursion. This is sometimes recoverable and leads to an error for the request causing the problem, but in other cases the Synapse process may crash altogether. It is possible to exploit this maliciously, either by malicious users on the homeserver, or by remote users sending URLs that a local user's client may automatically request a URL preview for. Remote users are not able to exploit this directly, because the URL preview endpoint is authenticated. Deployments with `url_preview_enabled: false` set in configuration are not affected. Deployments with `url_preview_enabled: true` set in configuration **are** affected. Deployments with no configuration value set for `url_preview_enabled` are not affected, because the default is `false`. Administrators of homeservers with URL previews enabled are advised to upgrade to v1.61.1 or higher. Users unable to upgrade should set `url_preview_enabled` to false.

Weakness: CWE-674

Which versions are affected by CVE-2022-31052?

3 open source packages ship an affected version, including matrix-synapse. It affects 2 products.

PackageAffectedFixed in
matrix-synapse PyPIAll versions1.61.1
matrix-synapse PyPIAll versions1.61.1
matrix-synapse PyPIAll versions1.61.1
Linux distribution packages (1)
matrix-synapse openSUSE:TumbleweedAll versions1.61.1-1.1

Products include Fedoraproject Fedora, Matrix Synapse.

How do I fix CVE-2022-31052?

Upgrade matrix-synapse to 1.61.1 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2022-31052 being exploited?

There is no known exploitation of CVE-2022-31052 in the wild and no public exploit code.

All Fedoraproject Fedora vulnerabilities

Sources

Also known as GHSA-22p3-qrh9-cx32, PYSEC-2022-224, UBUNTU-CVE-2022-31052, openSUSE-SU-2024:12160-1.

Is CVE-2022-31052 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free