{"answers":{"affected":"3 open source packages ship an affected version, including matrix-synapse. It affects 2 products.","exploited":"There is no known exploitation of CVE-2022-31052 in the wild and no public exploit code.","fix":"Upgrade matrix-synapse to 1.61.1 or later.","what":"CVE-2022-31052 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 28 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-31052 and fix it if it is affected.\n\nWhat it is: CVE-2022-31052 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 28 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-31052 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- matrix-synapse (PyPI): affected all versions; fixed in 1.61.1\n- matrix-synapse (PyPI): affected all versions; fixed in 1.61.1\n- matrix-synapse (PyPI): affected all versions; fixed in 1.61.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-31052/ (Markdown: https://insights.sbomify.com/CVE-2022-31052/index.md)","id":"CVE-2022-31052","markdown":"https://insights.sbomify.com/CVE-2022-31052/index.md","name":"CVE-2022-31052","record":{"aliases":["GHSA-22p3-qrh9-cx32","PYSEC-2022-224","UBUNTU-CVE-2022-31052","openSUSE-SU-2024:12160-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Matrix homeserver","requires_auth":"low_privilege","summary":"Authenticated users can crash Synapse servers via unbounded recursion in URL previews, requiring administrators to upgrade or disable the feature.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"synapse","vendor":"matrix"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-674","name":"Uncontrolled Recursion"}],"description":"Synapse is an open source home server implementation for the Matrix chat network. In versions prior to 1.61.1 URL previews of some web pages can exhaust the available stack space for the Synapse process due to unbounded recursion. This is sometimes recoverable and leads to an error for the request causing the problem, but in other cases the Synapse process may crash altogether. It is possible to exploit this maliciously, either by malicious users on the homeserver, or by remote users sending URLs that a local user's client may automatically request a URL preview for. Remote users are not able to exploit this directly, because the URL preview endpoint is authenticated. Deployments with `url_preview_enabled: false` set in configuration are not affected. Deployments with `url_preview_enabled: true` set in configuration **are** affected. Deployments with no configuration value set for `url_preview_enabled` are not affected, because the default is `false`. Administrators of homeservers with URL previews enabled are advised to upgrade to v1.61.1 or higher. Users unable to upgrade should set `url_preview_enabled` to false.","ecosystems":["PyPI","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"URL previews can crash Synapse media repositories or Synapse monoliths","id":"CVE-2022-31052","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"denial_of_service","year":"2022"},"n_packages":4,"n_references":5,"next":{"headline":"Signature forgery in Biscuit","id":"CVE-2022-31053"},"packages":[{"ecosystem":"PyPI","fixed":["1.61.1"],"introduced":["0"],"last_affected":[],"package":"matrix-synapse","purl":null,"source":"GHSA-22p3-qrh9-cx32"},{"ecosystem":"PyPI","fixed":["1.61.1"],"introduced":["0"],"last_affected":[],"package":"matrix-synapse","purl":"pkg:pypi/matrix-synapse","source":"GHSA-22p3-qrh9-cx32"},{"ecosystem":"PyPI","fixed":["1.61.1"],"introduced":["0"],"last_affected":[],"package":"matrix-synapse","purl":"pkg:pypi/matrix-synapse","source":"PYSEC-2022-224"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.61.1-1.1"],"introduced":["0"],"last_affected":[],"package":"matrix-synapse","purl":"pkg:rpm/opensuse/matrix-synapse\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:12160-1"}],"prev":{"headline":"Exposure of Sensitive Information to an Unauthorized Actor in semantic-release","id":"CVE-2022-31051"},"products":["synapse"],"published":"2022-06-28","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["matrix-org"]},"summary":"Authenticated users can crash Synapse servers via unbounded recursion in URL previews, requiring administrators to upgrade or disable the feature.","url":"https://insights.sbomify.com/CVE-2022-31052/"}