# CVE-2022-31052: URL previews can crash Synapse media repositories or Synapse monoliths

> Authenticated users can crash Synapse servers via unbounded recursion in URL previews, requiring administrators to upgrade or disable the feature.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jun 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-22p3-qrh9-cx32, PYSEC-2022-224, UBUNTU-CVE-2022-31052, openSUSE-SU-2024:12160-1

## What is CVE-2022-31052?

CVE-2022-31052 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 28 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Synapse is an open source home server implementation for the Matrix chat network. In versions prior to 1.61.1 URL previews of some web pages can exhaust the available stack space for the Synapse process due to unbounded recursion. This is sometimes recoverable and leads to an error for the request causing the problem, but in other cases the Synapse process may crash altogether. It is possible to exploit this maliciously, either by malicious users on the homeserver, or by remote users sending URLs that a local user's client may automatically request a URL preview for. Remote users are not able to exploit this directly, because the URL preview endpoint is authenticated. Deployments with `url_preview_enabled: false` set in configuration are not affected. Deployments with `url_preview_enabled: true` set in configuration **are** affected. Deployments with no configuration value set for `url_preview_enabled` are not affected, because the default is `false`. Administrators of homeservers with URL previews enabled are advised to upgrade to v1.61.1 or higher. Users unable to upgrade should set `url_preview_enabled` to false.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2022-31052?

3 open source packages ship an affected version, including matrix-synapse. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `matrix-synapse` | PyPI | All versions | 1.61.1 |
| `matrix-synapse` | PyPI | All versions | 1.61.1 |
| `matrix-synapse` | PyPI | All versions | 1.61.1 |
| `matrix-synapse` | openSUSE:Tumbleweed | All versions | 1.61.1-1.1 |

Products: Fedoraproject Fedora, Matrix Synapse.

## How do I fix CVE-2022-31052?

Upgrade matrix-synapse to 1.61.1 or later.

## Is CVE-2022-31052 being exploited?

There is no known exploitation of CVE-2022-31052 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31052 and fix it if it is affected.

What it is: CVE-2022-31052 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 28 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-31052 in the wild and no public exploit code.

Affected packages and fixed versions:
- matrix-synapse (PyPI): affected all versions; fixed in 1.61.1
- matrix-synapse (PyPI): affected all versions; fixed in 1.61.1
- matrix-synapse (PyPI): affected all versions; fixed in 1.61.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31052/ (Markdown: https://insights.sbomify.com/CVE-2022-31052/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31052
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31052
- OSV: https://osv.dev/vulnerability/CVE-2022-31052

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31052/
Summaries are generated and may contain mistakes; the official description above is the record.
