# CVE-2022-31055: Improper Access Control in kctf

> Attackers can bypass IP restrictions to access private CTF challenges due to broken source IP filtering in kctf.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 13 Jun 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-4g2v-6qc6-6jv5

## What is CVE-2022-31055?

CVE-2022-31055 is a high-severity missing authorization vulnerability in google kctf, published on 13 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

kCTF is a Kubernetes-based infrastructure for capture the flag (CTF) competitions. Prior to version 1.6.0, the kctf cluster set-src-ip-ranges was broken and allowed traffic from any IP. The problem has been patched in v1.6.0. As a workaround, those who want to test challenges privately can mark them as `public: false` and use `kctf chal debug port-forward` to connect.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2022-31055?

It affects 1 product.


Products: Google Kctf.

## How do I fix CVE-2022-31055?

No fix has been published for CVE-2022-31055 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-31055 being exploited?

There is no known exploitation of CVE-2022-31055 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31055 and fix it if it is affected.

What it is: CVE-2022-31055 is a high-severity missing authorization vulnerability in google kctf, published on 13 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-31055 in the wild and no public exploit code.

Affected product: google kctf. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31055/ (Markdown: https://insights.sbomify.com/CVE-2022-31055/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31055
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31055
- OSV: https://osv.dev/vulnerability/CVE-2022-31055

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31055/
Summaries are generated and may contain mistakes; the official description above is the record.
