{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-31059 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2022-31059 yet. Limit exposure of the affected software until one is available.","what":"CVE-2022-31059 is a medium-severity cross-site scripting vulnerability in discourse-calendar, published on 14 Jun 2022. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-31059 and fix it if it is affected.\n\nWhat it is: CVE-2022-31059 is a medium-severity cross-site scripting vulnerability in discourse-calendar, published on 14 Jun 2022. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-31059 in the wild and no public exploit code.\n\nAffected product: discourse-calendar. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-31059/ (Markdown: https://insights.sbomify.com/CVE-2022-31059/index.md)","id":"CVE-2022-31059","markdown":"https://insights.sbomify.com/CVE-2022-31059/index.md","name":"CVE-2022-31059","record":{"aliases":["GHSA-c783-x9vm-xxp5"],"analysis":{"component_type":"cms_plugin","fix_type":"patch","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"Discourse Calendar plugin","requires_auth":"high_privilege","summary":"Attackers can inject malicious scripts via event names in Discourse Calendar if Content Security Policy is disabled or modified.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"discourse_calendar","vendor":"discourse"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Discourse Calendar is a calendar plugin for Discourse, an open-source messaging app. Prior to version 1.0.1, parsing and rendering of Event names can be susceptible to cross-site scripting (XSS) attacks. This vulnerability only affects sites which have modified or disabled Discourse’s default Content Security Policy. This issue is patched in version 1.0.1 of the Discourse Calendar plugin. As a workaround, ensure that the Content Security Policy is enabled, and has not been modified in a way which would make it more vulnerable to XSS attacks.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Discourse Calendar Event names susceptible to Cross-site Scripting","id":"CVE-2022-31059","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2022"},"n_packages":0,"n_references":3,"next":{"headline":"Banner topic data is exposed on login-required Discourse sites","id":"CVE-2022-31060"},"packages":[],"prev":{"headline":"SQL injection via the field name of a tracker in Tuleap","id":"CVE-2022-31058"},"products":["discourse-calendar"],"published":"2022-06-14","related":[{"cvss_score":8,"headline":"Improper escaping of user input in discourse-calendar","id":"CVE-2023-43658","kev_date_added":null,"published":"2023-10-16"},{"cvss_score":4.3,"headline":"Insufficient control of region value length in discourse-calendar","id":"CVE-2024-21658","kev_date_added":null,"published":"2024-08-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["discourse"]},"summary":"Attackers can inject malicious scripts via event names in Discourse Calendar if Content Security Policy is disabled or modified.","url":"https://insights.sbomify.com/CVE-2022-31059/"}