# CVE-2022-31059: Discourse Calendar Event names susceptible to Cross-site Scripting

> Attackers can inject malicious scripts via event names in Discourse Calendar if Content Security Policy is disabled or modified.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 14 Jun 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-c783-x9vm-xxp5

## What is CVE-2022-31059?

CVE-2022-31059 is a medium-severity cross-site scripting vulnerability in discourse-calendar, published on 14 Jun 2022. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Discourse Calendar is a calendar plugin for Discourse, an open-source messaging app. Prior to version 1.0.1, parsing and rendering of Event names can be susceptible to cross-site scripting (XSS) attacks. This vulnerability only affects sites which have modified or disabled Discourse’s default Content Security Policy. This issue is patched in version 1.0.1 of the Discourse Calendar plugin. As a workaround, ensure that the Content Security Policy is enabled, and has not been modified in a way which would make it more vulnerable to XSS attacks.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-31059?

It affects 1 product.


Products: Discourse Discourse Calendar.

## How do I fix CVE-2022-31059?

No fix has been published for CVE-2022-31059 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-31059 being exploited?

There is no known exploitation of CVE-2022-31059 in the wild and no public exploit code.

## Other vulnerabilities in discourse-calendar

- [CVE-2023-43658](https://insights.sbomify.com/CVE-2023-43658/): Improper escaping of user input in discourse-calendar (high 8.0)
- [CVE-2024-21658](https://insights.sbomify.com/CVE-2024-21658/): Insufficient control of region value length in discourse-calendar (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31059 and fix it if it is affected.

What it is: CVE-2022-31059 is a medium-severity cross-site scripting vulnerability in discourse-calendar, published on 14 Jun 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-31059 in the wild and no public exploit code.

Affected product: discourse-calendar. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31059/ (Markdown: https://insights.sbomify.com/CVE-2022-31059/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31059
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31059
- OSV: https://osv.dev/vulnerability/CVE-2022-31059

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31059/
Summaries are generated and may contain mistakes; the official description above is the record.
