CVE-2022-31060 Banner topic data is exposed on login-required Discourse sites

Medium 5.3 Published Updated

Attackers can view banner topic data on Discourse sites configured to require login, exposing potentially sensitive information.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-31060?

CVE-2022-31060 is a medium-severity vulnerability in Discourse Discourse, published on 14 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Discourse is an open-source discussion platform. Prior to version 2.8.4 in the `stable` branch and version `2.9.0.beta5` in the `beta` and `tests-passed` branches, banner topic data is exposed on login-required sites. This issue is patched in version 2.8.4 in the `stable` branch and version `2.9.0.beta5` in the `beta` and `tests-passed` branches of Discourse. As a workaround, one may disable banners.

Weakness: CWE-200

Which versions are affected by CVE-2022-31060?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions2.8.4

Products include Discourse Discourse.

How do I fix CVE-2022-31060?

Upgrade discourse to 2.8.4 or later.

Is CVE-2022-31060 being exploited?

There is no known exploitation of CVE-2022-31060 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2022-31060, GHSA-5f4f-35fx-gqhq.

Is CVE-2022-31060 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free