{"answers":{"affected":"2 open source packages ship an affected version, including @finastra/nestjs-proxy. It affects 2 products.","exploited":"There is no known exploitation of CVE-2022-31070 in the wild and no public exploit code.","fix":"Upgrade @finastra/nestjs-proxy to 0.7.0 or later.","what":"CVE-2022-31070 is a medium-severity vulnerability in finastra-nodejs-libs, published on 15 Jun 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-31070 and fix it if it is affected.\n\nWhat it is: CVE-2022-31070 is a medium-severity vulnerability in finastra-nodejs-libs, published on 15 Jun 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-31070 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @finastra/nestjs-proxy (npm): affected all versions; fixed in 0.7.0\n- @finastra/nestjs-proxy (npm): affected all versions; fixed in 0.7.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-31070/ (Markdown: https://insights.sbomify.com/CVE-2022-31070/index.md)","id":"CVE-2022-31070","markdown":"https://insights.sbomify.com/CVE-2022-31070/index.md","name":"CVE-2022-31070","record":{"aliases":["GHSA-77mv-4rg7-r8qv"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"NestJS proxy library","requires_auth":"high_privilege","summary":"The library forwarded sensitive cookies to backend services by default, potentially exposing session data to unintended recipients.","user_interaction":"required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"nestjs-proxy","vendor":"finastra"},{"product":"nestjs-proxy","vendor":"nestjs-proxy_project"}],"cvss":{"score":5.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"NestJS Proxy is a NestJS module to decorate and proxy calls. Prior to version 0.7.0, the nestjs-proxy library did not have a way to block sensitive cookies (e.g. session cookies) from being forwarded to backend services configured by the application developer. This could have led to sensitive cookies being inadvertently exposed to such services that should not see them. The patched version now blocks cookies from being forwarded by default. However developers can configure an allow-list of cookie names by using the `allowedCookies` config setting. This issue has been fixed in version 0.7.0 of `@finastra/nestjs-proxy`. Users of `@ffdc/nestjs-proxy` are advised that this package has been deprecated and is no longer being maintained or receiving updates. Such users should update their package.json file to use `@finastra/nestjs-proxy` instead.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Potential Sensitive Cookie Exposure in NPM Packages @finastra/nestjs-proxy, @ffdc/nestjs-proxy","id":"CVE-2022-31070","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"information_disclosure","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Octopoller gem published with world-writable files","id":"CVE-2022-31071"},"packages":[{"ecosystem":"npm","fixed":["0.7.0"],"introduced":["0"],"last_affected":[],"package":"@finastra/nestjs-proxy","purl":null,"source":"GHSA-77mv-4rg7-r8qv"},{"ecosystem":"npm","fixed":["0.7.0"],"introduced":["0"],"last_affected":[],"package":"@finastra/nestjs-proxy","purl":"pkg:npm/%40finastra/nestjs-proxy","source":"GHSA-77mv-4rg7-r8qv"}],"prev":{"headline":"Potential Authorization Header Exposure in NPM Packages @finastra/nestjs-proxy, @ffdc/nestjs-proxy","id":"CVE-2022-31069"},"products":["finastra-nodejs-libs"],"published":"2022-06-15","related":[{"cvss_score":5.8,"headline":"Potential Authorization Header Exposure in NPM Packages @finastra/nestjs-proxy, @ffdc/nestjs-proxy","id":"CVE-2022-31069","kev_date_added":null,"published":"2022-06-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["Finastra"]},"summary":"The library forwarded sensitive cookies to backend services by default, potentially exposing session data to unintended recipients.","url":"https://insights.sbomify.com/CVE-2022-31070/"}