# CVE-2022-31070: Potential Sensitive Cookie Exposure in NPM Packages @finastra/nestjs-proxy, @ffdc/nestjs-proxy

> The library forwarded sensitive cookies to backend services by default, potentially exposing session data to unintended recipients.

- **Severity:** Medium 5.8 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Jun 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-77mv-4rg7-r8qv

## What is CVE-2022-31070?

CVE-2022-31070 is a medium-severity vulnerability in finastra-nodejs-libs, published on 15 Jun 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

NestJS Proxy is a NestJS module to decorate and proxy calls. Prior to version 0.7.0, the nestjs-proxy library did not have a way to block sensitive cookies (e.g. session cookies) from being forwarded to backend services configured by the application developer. This could have led to sensitive cookies being inadvertently exposed to such services that should not see them. The patched version now blocks cookies from being forwarded by default. However developers can configure an allow-list of cookie names by using the `allowedCookies` config setting. This issue has been fixed in version 0.7.0 of `@finastra/nestjs-proxy`. Users of `@ffdc/nestjs-proxy` are advised that this package has been deprecated and is no longer being maintained or receiving updates. Such users should update their package.json file to use `@finastra/nestjs-proxy` instead.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2022-31070?

2 open source packages ship an affected version, including @finastra/nestjs-proxy. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@finastra/nestjs-proxy` | npm | All versions | 0.7.0 |
| `@finastra/nestjs-proxy` | npm | All versions | 0.7.0 |

Products: Finastra Nestjs-Proxy, Nestjs-Proxy Project Nestjs-Proxy.

## How do I fix CVE-2022-31070?

Upgrade @finastra/nestjs-proxy to 0.7.0 or later.

## Is CVE-2022-31070 being exploited?

There is no known exploitation of CVE-2022-31070 in the wild and no public exploit code.

## Other vulnerabilities in finastra-nodejs-libs

- [CVE-2022-31069](https://insights.sbomify.com/CVE-2022-31069/): Potential Authorization Header Exposure in NPM Packages @finastra/nestjs-proxy, @ffdc/nestjs-proxy (medium 5.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31070 and fix it if it is affected.

What it is: CVE-2022-31070 is a medium-severity vulnerability in finastra-nodejs-libs, published on 15 Jun 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-31070 in the wild and no public exploit code.

Affected packages and fixed versions:
- @finastra/nestjs-proxy (npm): affected all versions; fixed in 0.7.0
- @finastra/nestjs-proxy (npm): affected all versions; fixed in 0.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31070/ (Markdown: https://insights.sbomify.com/CVE-2022-31070/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31070
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31070
- OSV: https://osv.dev/vulnerability/CVE-2022-31070

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31070/
Summaries are generated and may contain mistakes; the official description above is the record.
