CVE-2022-31071 Octopoller gem published with world-writable files
Attackers with local access can modify world-writable files in the Octopoller gem, potentially altering application behavior.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-31071?
CVE-2022-31071 is a low-severity vulnerability in octokit octopoller.rb, published on 15 Jun 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
Octopoller is a micro gem for polling and retrying. Version 0.2.0 of the octopoller gem was published containing world-writeable files. Specifically, the gem was packed with files having their permissions set to `-rw-rw-rw-` (i.e. 0666) instead of `rw-r--r--` (i.e. 0644). This means everyone who is not the owner (Group and Public) with access to the instance where this release had been installed could modify the world-writable files from this gem. This issue is patched in Octopoller 0.3.0. Two workarounds are available. Users can use the previous version of the gem, v0.1.0. Alternatively, users can modify the file permissions manually until they are able to upgrade to the latest version.
Weakness: CWE-276
Which versions are affected by CVE-2022-31071?
2 open source packages ship an affected version, including octopoller. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
octopoller RubyGems | From 0.2.0 | 0.3.0 |
octopoller RubyGems | From 0.2.0 | 0.3.0 |
Products include Octopoller Project Octopoller.
How do I fix CVE-2022-31071?
Upgrade octopoller to 0.3.0 or later.
Is CVE-2022-31071 being exploited?
There is no known exploitation of CVE-2022-31071 in the wild and no public exploit code.
Sources
Also known as GHSA-26qj-cr27-r5c4.