CVE-2022-31073 KubeEdge Edge ServiceBus module DoS

Medium 6.5 Published Updated

Attackers can cause memory exhaustion and denial of service on KubeEdge edge nodes by sending large HTTP requests to the ServiceBus module.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2022-31073?

CVE-2022-31073 is a medium-severity denial of service vulnerability in kubeedge, published on 11 Jul 2022. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

KubeEdge is an open source system for extending native containerized application orchestration capabilities to hosts at Edge. Prior to versions 1.11.1, 1.10.2, and 1.9.4, the ServiceBus server on the edge side may be susceptible to a DoS attack if an HTTP request containing a very large Body is sent to it. It is possible for the node to be exhausted of memory. The consequence of the exhaustion is that other services on the node, e.g. other containers, will be unable to allocate memory and thus causing a denial of service. Malicious apps accidentally pulled by users on the host and have the access to send HTTP requests to localhost may make an attack. It will be affected only when users enable the `ServiceBus` module in the config file `edgecore.yaml`. This bug has been fixed in Kubeedge 1.11.1, 1.10.2, and 1.9.4. As a workaround, disable the `ServiceBus` module in the config file `edgecore.yaml`.

Weakness: CWE-400

Which versions are affected by CVE-2022-31073?

7 open source packages ship an affected version, including github.com/kubeedge/kubeedge. It affects 1 product.

PackageAffectedFixed in
github.com/kubeedge/kubeedge GoAll versions1.9.4, 1.10.2, 1.11.1
github.com/kubeedge/kubeedge GoAll versions1.9.4
github.com/kubeedge/kubeedge GoAll versions1.9.4
github.com/kubeedge/kubeedge GoFrom 1.10.01.10.2
github.com/kubeedge/kubeedge GoFrom 1.10.01.10.2
github.com/kubeedge/kubeedge GoFrom 1.11.01.11.1
1 more packages
github.com/kubeedge/kubeedge GoFrom 1.11.01.11.1

Products include Linuxfoundation Kubeedge.

How do I fix CVE-2022-31073?

Upgrade github.com/kubeedge/kubeedge to a fixed version for your release line: 1.9.4, 1.10.2 or 1.11.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2022-31073 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31073 exists.

Sources

Also known as GHSA-vwm6-qc77-v2rh, GO-2022-0507.

Is CVE-2022-31073 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free