CVE-2022-31074 KubeEdge Cloud AdmissionController component DoS

Medium 4.5 Published Updated

Attackers can cause denial of service in KubeEdge Cloud AdmissionController by sending HTTP requests with large bodies, requiring an upgrade to fixed versions.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2022-31074?

CVE-2022-31074 is a medium-severity denial of service vulnerability in kubeedge, published on 11 Jul 2022. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

KubeEdge is an open source system for extending native containerized application orchestration capabilities to hosts at Edge. Prior to versions 1.11.1, 1.10.2, and 1.9.4, several endpoints in the Cloud AdmissionController may be susceptible to a DoS attack if an HTTP request containing a very large Body is sent to it. The consequence of the exhaustion is that the Cloud AdmissionController will be in denial of service. This bug has been fixed in Kubeedge 1.11.1, 1.10.2, and 1.9.4. There is currently no known workaround.

Weakness: CWE-400

Which versions are affected by CVE-2022-31074?

7 open source packages ship an affected version, including github.com/kubeedge/kubeedge. It affects 1 product.

PackageAffectedFixed in
github.com/kubeedge/kubeedge GoAll versions1.9.4, 1.10.2, 1.11.1
github.com/kubeedge/kubeedge GoAll versions1.9.4
github.com/kubeedge/kubeedge GoAll versions1.9.4
github.com/kubeedge/kubeedge GoFrom 1.10.01.10.2
github.com/kubeedge/kubeedge GoFrom 1.10.01.10.2
github.com/kubeedge/kubeedge GoFrom 1.11.01.11.1
1 more packages
github.com/kubeedge/kubeedge GoFrom 1.11.01.11.1

Products include Linuxfoundation Kubeedge.

How do I fix CVE-2022-31074?

Upgrade github.com/kubeedge/kubeedge to a fixed version for your release line: 1.9.4, 1.10.2 or 1.11.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2022-31074 being exploited?

There is no known exploitation of CVE-2022-31074 in the wild and no public exploit code.

Sources

Also known as GHSA-w52j-3457-q9wr, GO-2022-0508.

Is CVE-2022-31074 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free