CVE-2022-31075 KubeEdge DoS when signing the CSR from EdgeCore
Authorized users can crash KubeEdge CloudHub via memory exhaustion by sending large HTTP requests to the certificate endpoint.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-31075?
CVE-2022-31075 is a medium-severity denial of service vulnerability in kubeedge, published on 11 Jul 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
KubeEdge is an open source system for extending native containerized application orchestration capabilities to hosts at Edge. Prior to versions 1.11.1, 1.10.2, and 1.9.4, EdgeCore may be susceptible to a DoS attack on CloudHub if an attacker was to send a well-crafted HTTP request to `/edge.crt`. If an attacker can send a well-crafted HTTP request to CloudHub, and that request has a very large body, that request can crash the HTTP service through a memory exhaustion vector. The request body is being read into memory, and a body that is larger than the available memory can lead to a successful attack. Because the request would have to make it through authorization, only authorized users may perform this attack. The consequence of the exhaustion is that CloudHub will be in denial of service. KubeEdge is affected only when users enable the CloudHub module in the file `cloudcore.yaml`. This bug has been fixed in Kubeedge 1.11.1, 1.10.2, and 1.9.4. As a workaround, disable the CloudHub switch in the config file `cloudcore.yaml`.
Which versions are affected by CVE-2022-31075?
7 open source packages ship an affected version, including github.com/kubeedge/kubeedge. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/kubeedge/kubeedge Go | All versions | 1.9.4, 1.10.2, 1.11.1 |
github.com/kubeedge/kubeedge Go | All versions | 1.9.4 |
github.com/kubeedge/kubeedge Go | All versions | 1.9.4 |
github.com/kubeedge/kubeedge Go | From 1.10.0 | 1.10.2 |
github.com/kubeedge/kubeedge Go | From 1.10.0 | 1.10.2 |
github.com/kubeedge/kubeedge Go | From 1.11.0 | 1.11.1 |
1 more packages
github.com/kubeedge/kubeedge Go | From 1.11.0 | 1.11.1 |
Products include Linuxfoundation Kubeedge.
How do I fix CVE-2022-31075?
Upgrade github.com/kubeedge/kubeedge to a fixed version for your release line: 1.9.4, 1.10.2 or 1.11.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2022-31075 being exploited?
There is no known exploitation of CVE-2022-31075 in the wild and no public exploit code.
Other vulnerabilities in kubeedge
- CVE-2022-31073 KubeEdge Edge ServiceBus module DoS
- CVE-2022-31074 KubeEdge Cloud AdmissionController component DoS
- CVE-2022-31078 KubeEdge CloudCore Router memory exhaustion
- CVE-2022-31079 KubeEdge Cloud Stream and Edge Stream DoS from large stream message
- CVE-2022-31080 KubeEdge Websocket Client in package Viaduct: DoS from large response message
Sources
Also known as GHSA-x3px-2p95-f6jr, GO-2022-0509.