# CVE-2022-31075: KubeEdge DoS when signing the CSR from EdgeCore

> Authorized users can crash KubeEdge CloudHub via memory exhaustion by sending large HTTP requests to the certificate endpoint.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jul 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-x3px-2p95-f6jr, GO-2022-0509

## What is CVE-2022-31075?

CVE-2022-31075 is a medium-severity denial of service vulnerability in kubeedge, published on 11 Jul 2022. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

KubeEdge is an open source system for extending native containerized application orchestration capabilities to hosts at Edge. Prior to versions 1.11.1, 1.10.2, and 1.9.4, EdgeCore may be susceptible to a DoS attack on CloudHub if an attacker was to send a well-crafted HTTP request to `/edge.crt`. If an attacker can send a well-crafted HTTP request to CloudHub, and that request has a very large body, that request can crash the HTTP service through a memory exhaustion vector. The request body is being read into memory, and a body that is larger than the available memory can lead to a successful attack. Because the request would have to make it through authorization, only authorized users may perform this attack. The consequence of the exhaustion is that CloudHub will be in denial of service. KubeEdge is affected only when users enable the CloudHub module in the file `cloudcore.yaml`. This bug has been fixed in Kubeedge 1.11.1, 1.10.2, and 1.9.4. As a workaround, disable the CloudHub switch in the config file `cloudcore.yaml`.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2022-31075?

7 open source packages ship an affected version, including github.com/kubeedge/kubeedge. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/kubeedge/kubeedge` | Go | All versions | 1.9.4, 1.10.2, 1.11.1 |
| `github.com/kubeedge/kubeedge` | Go | All versions | 1.9.4 |
| `github.com/kubeedge/kubeedge` | Go | All versions | 1.9.4 |
| `github.com/kubeedge/kubeedge` | Go | From 1.10.0 | 1.10.2 |
| `github.com/kubeedge/kubeedge` | Go | From 1.10.0 | 1.10.2 |
| `github.com/kubeedge/kubeedge` | Go | From 1.11.0 | 1.11.1 |
| `github.com/kubeedge/kubeedge` | Go | From 1.11.0 | 1.11.1 |

Products: Linuxfoundation Kubeedge.

## How do I fix CVE-2022-31075?

Upgrade github.com/kubeedge/kubeedge to a fixed version for your release line: 1.9.4, 1.10.2 or 1.11.1.

## Is CVE-2022-31075 being exploited?

There is no known exploitation of CVE-2022-31075 in the wild and no public exploit code.

## Other vulnerabilities in kubeedge

- [CVE-2022-31073](https://insights.sbomify.com/CVE-2022-31073/): KubeEdge Edge ServiceBus module DoS (medium 6.5)
- [CVE-2022-31074](https://insights.sbomify.com/CVE-2022-31074/): KubeEdge Cloud AdmissionController component DoS (medium 4.5)
- [CVE-2022-31078](https://insights.sbomify.com/CVE-2022-31078/): KubeEdge CloudCore Router memory exhaustion (medium 4.4)
- [CVE-2022-31079](https://insights.sbomify.com/CVE-2022-31079/): KubeEdge Cloud Stream and Edge Stream DoS from large stream message (medium 4.4)
- [CVE-2022-31080](https://insights.sbomify.com/CVE-2022-31080/): KubeEdge Websocket Client in package Viaduct: DoS from large response message (medium 4.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31075 and fix it if it is affected.

What it is: CVE-2022-31075 is a medium-severity denial of service vulnerability in kubeedge, published on 11 Jul 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-31075 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/kubeedge/kubeedge (Go): affected all versions; fixed in 1.9.4, 1.10.2, 1.11.1
- github.com/kubeedge/kubeedge (Go): affected all versions; fixed in 1.9.4
- github.com/kubeedge/kubeedge (Go): affected all versions; fixed in 1.9.4
- github.com/kubeedge/kubeedge (Go): affected from 1.10.0; fixed in 1.10.2
- github.com/kubeedge/kubeedge (Go): affected from 1.10.0; fixed in 1.10.2
- github.com/kubeedge/kubeedge (Go): affected from 1.11.0; fixed in 1.11.1
- github.com/kubeedge/kubeedge (Go): affected from 1.11.0; fixed in 1.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31075/ (Markdown: https://insights.sbomify.com/CVE-2022-31075/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31075
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31075
- OSV: https://osv.dev/vulnerability/CVE-2022-31075

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31075/
Summaries are generated and may contain mistakes; the official description above is the record.
