# CVE-2022-31079: KubeEdge Cloud Stream and Edge Stream DoS from large stream message

> Authenticated attackers can cause denial of service in KubeEdge Cloud and Edge Stream servers by sending large messages, requiring specific module enablement.

- **Severity:** Medium 4.4 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jul 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-wrcr-x4qj-j543, GO-2022-0511

## What is CVE-2022-31079?

CVE-2022-31079 is a medium-severity denial of service vulnerability in kubeedge, published on 11 Jul 2022. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

KubeEdge is an open source system for extending native containerized application orchestration capabilities to hosts at Edge. Prior to versions 1.11.1, 1.10.2, and 1.9.4, the Cloud Stream server and the Edge Stream server reads the entire message into memory without imposing a limit on the size of this message. An attacker can exploit this by sending a large message to exhaust memory and cause a DoS. The Cloud Stream server and the Edge Stream server are under DoS attack in this case. The consequence of the exhaustion is that the CloudCore and EdgeCore will be in a denial of service. Only an authenticated user can cause this issue. It will be affected only when users enable `cloudStream` module in the config file `cloudcore.yaml` and enable `edgeStream` module in the config file `edgecore.yaml`. This bug has been fixed in Kubeedge 1.11.1, 1.10.2, and 1.9.4. As a workaround, disable cloudStream module in the config file `cloudcore.yaml` and disable edgeStream module in the config file `edgecore.yaml`.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2022-31079?

7 open source packages ship an affected version, including github.com/kubeedge/kubeedge. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/kubeedge/kubeedge` | Go | All versions | 1.9.4, 1.10.2, 1.11.1 |
| `github.com/kubeedge/kubeedge` | Go | All versions | 1.9.4 |
| `github.com/kubeedge/kubeedge` | Go | All versions | 1.9.4 |
| `github.com/kubeedge/kubeedge` | Go | From 1.10.0 | 1.10.2 |
| `github.com/kubeedge/kubeedge` | Go | From 1.10.0 | 1.10.2 |
| `github.com/kubeedge/kubeedge` | Go | From 1.11.0 | 1.11.1 |
| `github.com/kubeedge/kubeedge` | Go | From 1.11.0 | 1.11.1 |

Products: Linuxfoundation Kubeedge.

## How do I fix CVE-2022-31079?

Upgrade github.com/kubeedge/kubeedge to a fixed version for your release line: 1.9.4, 1.10.2 or 1.11.1.

## Is CVE-2022-31079 being exploited?

There is no known exploitation of CVE-2022-31079 in the wild and no public exploit code.

## Other vulnerabilities in kubeedge

- [CVE-2022-31073](https://insights.sbomify.com/CVE-2022-31073/): KubeEdge Edge ServiceBus module DoS (medium 6.5)
- [CVE-2022-31075](https://insights.sbomify.com/CVE-2022-31075/): KubeEdge DoS when signing the CSR from EdgeCore (medium 4.9)
- [CVE-2022-31074](https://insights.sbomify.com/CVE-2022-31074/): KubeEdge Cloud AdmissionController component DoS (medium 4.5)
- [CVE-2022-31078](https://insights.sbomify.com/CVE-2022-31078/): KubeEdge CloudCore Router memory exhaustion (medium 4.4)
- [CVE-2022-31080](https://insights.sbomify.com/CVE-2022-31080/): KubeEdge Websocket Client in package Viaduct: DoS from large response message (medium 4.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31079 and fix it if it is affected.

What it is: CVE-2022-31079 is a medium-severity denial of service vulnerability in kubeedge, published on 11 Jul 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-31079 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/kubeedge/kubeedge (Go): affected all versions; fixed in 1.9.4, 1.10.2, 1.11.1
- github.com/kubeedge/kubeedge (Go): affected all versions; fixed in 1.9.4
- github.com/kubeedge/kubeedge (Go): affected all versions; fixed in 1.9.4
- github.com/kubeedge/kubeedge (Go): affected from 1.10.0; fixed in 1.10.2
- github.com/kubeedge/kubeedge (Go): affected from 1.10.0; fixed in 1.10.2
- github.com/kubeedge/kubeedge (Go): affected from 1.11.0; fixed in 1.11.1
- github.com/kubeedge/kubeedge (Go): affected from 1.11.0; fixed in 1.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31079/ (Markdown: https://insights.sbomify.com/CVE-2022-31079/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31079
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31079
- OSV: https://osv.dev/vulnerability/CVE-2022-31079

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31079/
Summaries are generated and may contain mistakes; the official description above is the record.
