CVE-2022-31080 KubeEdge Websocket Client in package Viaduct: DoS from large response message

Medium 4.4 Published Updated

An attacker can cause a denial of service via memory exhaustion by sending large WebSocket responses to the KubeEdge viaduct client.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-31080?

CVE-2022-31080 is a medium-severity denial of service vulnerability in kubeedge, published on 11 Jul 2022. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

KubeEdge is an open source system for extending native containerized application orchestration capabilities to hosts at Edge. Prior to versions 1.11.1, 1.10.2, and 1.9.4, a large response received by the viaduct WSClient can cause a DoS from memory exhaustion. The entire body of the response is being read into memory which could allow an attacker to send a request that returns a response with a large body. The consequence of the exhaustion is that the process which invokes a WSClient will be in a denial of service. The software is affected If users who are authenticated to the edge side connect to `cloudhub` from the edge side through WebSocket protocol. This bug has been fixed in Kubeedge 1.11.1, 1.10.2, and 1.9.4. There are currently no known workarounds.

Weakness: CWE-770, CWE-400

Which versions are affected by CVE-2022-31080?

7 open source packages ship an affected version, including github.com/kubeedge/kubeedge. It affects 1 product.

PackageAffectedFixed in
github.com/kubeedge/kubeedge GoAll versions1.9.4, 1.10.2, 1.11.1
github.com/kubeedge/kubeedge GoAll versions1.9.4
github.com/kubeedge/kubeedge GoAll versions1.9.4
github.com/kubeedge/kubeedge GoFrom 1.10.01.10.2
github.com/kubeedge/kubeedge GoFrom 1.10.01.10.2
github.com/kubeedge/kubeedge GoFrom 1.11.01.11.1
1 more packages
github.com/kubeedge/kubeedge GoFrom 1.11.01.11.1

Products include Linuxfoundation Kubeedge.

How do I fix CVE-2022-31080?

Upgrade github.com/kubeedge/kubeedge to a fixed version for your release line: 1.9.4, 1.10.2 or 1.11.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2022-31080 being exploited?

There is no known exploitation of CVE-2022-31080 in the wild and no public exploit code.

Sources

Also known as GHSA-6wvc-6pww-qr4r, GO-2022-0512.

Is CVE-2022-31080 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free