CVE-2022-31083 Authentication bypass in Parse Server Apple Game Center auth adapter
Attackers can bypass Apple Game Center authentication in Parse Server by providing a fake certificate URL, allowing unauthorized access.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-31083?
CVE-2022-31083 is a high-severity authentication bypass vulnerability in Parseplatform Parse-Server, published on 17 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 4.10.11 and 5.2.2, the certificate in the Parse Server Apple Game Center auth adapter not validated. As a result, authentication could potentially be bypassed by making a fake certificate accessible via certain Apple domains and providing the URL to that certificate in an authData object. Versions 4.0.11 and 5.2.2 prevent this by introducing a new `rootCertificateUrl` property to the Parse Server Apple Game Center auth adapter which takes the URL to the root certificate of Apple's Game Center authentication certificate. If no value is set, the `rootCertificateUrl` property defaults to the URL of the current root certificate as of May 27, 2022. Keep in mind that the root certificate can change at any time and that it is the developer's responsibility to keep the root certificate URL up-to-date when using the Parse Server Apple Game Center auth adapter. There are no known workarounds for this issue.
Which versions are affected by CVE-2022-31083?
5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
parse-server npm | All versions | 4.10.11 |
parse-server npm | All versions | 4.10.11 |
parse-server npm | From 5.0.0 | 5.2.2 |
parse-server npm | From 5.0.0 | 5.2.2 |
parse Bitnami | All versions | 4.10.11, 5.2.2 |
Products include Parseplatform Parse-Server.
How do I fix CVE-2022-31083?
Upgrade parse-server to a fixed version for your release line: 4.10.11 or 5.2.2.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2022-31083 being exploited?
There is no known exploitation of CVE-2022-31083 in the wild and no public exploit code.
Other vulnerabilities in Parseplatform Parse-Server
- CVE-2026-30966 Parse Server role escalation and CLP bypass via direct `_Join` table write
- CVE-2024-27298 Parse Server literalizeRegexPart SQL Injection
- CVE-2022-24760 Command Injection in Parse server
- CVE-2026-30965 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter
- CVE-2023-36475 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution
Sources
Also known as BIT-parse-2022-31083, GHSA-rh9j-f5f8-rvgc.