# CVE-2022-31084: Unauthenticated Remote Code Execution in ldap-account-manager

> Unauthenticated attackers can achieve remote code execution in LDAP Account Manager by injecting arguments into arbitrary class instantiations.

- **Severity:** Critical 9.0 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jun 2022
- **Updated:** 22 Apr 2025
- **Also known as:** DEBIAN-CVE-2022-31084, GHSA-r387-grjx-qgvw, UBUNTU-CVE-2022-31084

## What is CVE-2022-31084?

CVE-2022-31084 is a critical code injection vulnerability in Debian Debian Linux, published on 27 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

LDAP Account Manager (LAM) is a webfrontend for managing entries (e.g. users, groups, DHCP settings) stored in an LDAP directory. In versions prior to 8.0 There are cases where LAM instantiates objects from arbitrary classes. An attacker can inject the first constructor argument. This can lead to code execution if non-LAM classes are instantiated that execute code during object creation. This issue has been fixed in version 8.0.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2022-31084?

It affects 2 products.


Products: Debian Debian Linux, Ldap-Account-Manager Ldap Account Manager.

## How do I fix CVE-2022-31084?

Upgrade to a fixed version.

## Is CVE-2022-31084 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31084 exists.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31084 and fix it if it is affected.

What it is: CVE-2022-31084 is a critical code injection vulnerability in Debian Debian Linux, published on 27 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31084 exists.

Affected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31084/ (Markdown: https://insights.sbomify.com/CVE-2022-31084/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31084
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31084
- OSV: https://osv.dev/vulnerability/CVE-2022-31084

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31084/
Summaries are generated and may contain mistakes; the official description above is the record.
