# CVE-2022-31085: Missing Encryption of Sensitive Data in ldap-account-manager

> Attackers can read LDAP credentials from session files if PHP OpenSSL is missing or encryption is disabled, exposing sensitive directory access details.

- **Severity:** Medium 5.5 (`CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jun 2022
- **Updated:** 23 Apr 2025
- **Also known as:** DEBIAN-CVE-2022-31085, GHSA-6m3q-5c84-6h6j, UBUNTU-CVE-2022-31085

## What is CVE-2022-31085?

CVE-2022-31085 is a medium-severity vulnerability in Debian Debian Linux, published on 27 Jun 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

LDAP Account Manager (LAM) is a webfrontend for managing entries (e.g. users, groups, DHCP settings) stored in an LDAP directory. In versions prior to 8.0 the session files include the LDAP user name and password in clear text if the PHP OpenSSL extension is not installed or encryption is disabled by configuration. This issue has been fixed in version 8.0. Users unable to upgrade should install the PHP OpenSSL extension and make sure session encryption is enabled in LAM main configuration.

Weakness: CWE-522 (Insufficiently Protected Credentials), CWE-311 (Missing Encryption of Sensitive Data)

## Which versions are affected by CVE-2022-31085?

It affects 2 products.


Products: Debian Debian Linux, Ldap-Account-Manager Ldap Account Manager.

## How do I fix CVE-2022-31085?

Upgrade to a fixed version.

## Is CVE-2022-31085 being exploited?

There is no known exploitation of CVE-2022-31085 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31085 and fix it if it is affected.

What it is: CVE-2022-31085 is a medium-severity vulnerability in Debian Debian Linux, published on 27 Jun 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-31085 in the wild and no public exploit code.

Affected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31085/ (Markdown: https://insights.sbomify.com/CVE-2022-31085/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31085
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31085
- OSV: https://osv.dev/vulnerability/CVE-2022-31085

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31085/
Summaries are generated and may contain mistakes; the official description above is the record.
