# CVE-2022-31097: Stored XSS in Grafana's Unified Alerting

> Stored XSS in Grafana Unified Alerting allows attackers to escalate privileges from editor to admin by tricking admins into clicking malicious links.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Jul 2022
- **Updated:** 28 Jan 2026
- **Also known as:** BIT-grafana-2022-31097, GHSA-vw7q-p2qg-4m5f, GO-2024-2857, MINI-345r-92j2-9982, MINI-4p8r-5wpj-mm6w, MINI-6mmr-33mm-7698, MINI-7grx-wfw9-xqw9, MINI-8r2x-h5hm-rq97, MINI-9592-9r95-q4h5, MINI-c734-256w-m8pc, MINI-c7r3-pc63-ghvx, MINI-cgm4-j72g-2w44, MINI-gjxr-878p-34qj, MINI-jgj2-wqc9-2r7x, MINI-mjrm-6m4v-pj63, MINI-r5mj-gq7x-79j3, MINI-rj4r-fpq4-h958, MINI-rvqw-m99f-r7qr, MINI-w77p-392v-6j49, MINI-x884-qrwx-q7cp, UBUNTU-CVE-2022-31097

## What is CVE-2022-31097?

CVE-2022-31097 is a high-severity cross-site scripting vulnerability in Grafana Grafana, published on 15 Jul 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Grafana is an open-source platform for monitoring and observability. Versions on the 8.x and 9.x branch prior to 9.0.3, 8.5.9, 8.4.10, and 8.3.10 are vulnerable to stored cross-site scripting via the Unified Alerting feature of Grafana. An attacker can exploit this vulnerability to escalate privilege from editor to admin by tricking an authenticated admin to click on a link. Versions 9.0.3, 8.5.9, 8.4.10, and 8.3.10 contain a patch. As a workaround, it is possible to disable alerting or use legacy alerting.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-31097?

10 open source packages ship an affected version, including github.com/grafana/grafana and grafana. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/grafana/grafana` | Go | All versions | None |
| `github.com/grafana/grafana` | Go | From 8.0.0 | 8.3.10 |
| `github.com/grafana/grafana` | Go | From 8.0.0 | 8.3.10 |
| `github.com/grafana/grafana` | Go | From 8.4.0 | 8.4.10 |
| `github.com/grafana/grafana` | Go | From 8.4.0 | 8.4.10 |
| `github.com/grafana/grafana` | Go | From 8.5.0 | 8.5.9 |
| `github.com/grafana/grafana` | Go | From 8.5.0 | 8.5.9 |
| `github.com/grafana/grafana` | Go | From 9.0.0 | 9.0.3 |
| `github.com/grafana/grafana` | Go | From 9.0.0 | 9.0.3 |
| `grafana` | Bitnami | From 8.0.0 | 8.3.10, 8.4.10, 8.5.9, 9.0.3 |

Products: Grafana Grafana, Netapp E-Series Performance Analyzer.

## How do I fix CVE-2022-31097?

Upgrade github.com/grafana/grafana to a fixed version for your release line: 8.3.10, 8.4.10, 8.5.9 or 9.0.3.

## Is CVE-2022-31097 being exploited?

There is no known exploitation of CVE-2022-31097 in the wild and no public exploit code.

## Other vulnerabilities in Grafana Grafana

- [CVE-2021-43798](https://insights.sbomify.com/CVE-2021-43798/): Grafana Path Traversal (high 7.5, exploited in the wild)
- [CVE-2025-41115](https://insights.sbomify.com/CVE-2025-41115/): Incorrect privilege assignment (critical 10.0)
- [CVE-2022-39328](https://insights.sbomify.com/CVE-2022-39328/): Grafana vulnerable to race condition allowing privilege escalation (critical 9.8)
- [CVE-2022-28660](https://insights.sbomify.com/CVE-2022-28660/): Auth bypass in n/a (critical 9.8)
- [CVE-2022-26148](https://insights.sbomify.com/CVE-2022-26148/): Information disclosure in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31097 and fix it if it is affected.

What it is: CVE-2022-31097 is a high-severity cross-site scripting vulnerability in Grafana Grafana, published on 15 Jul 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-31097 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/grafana/grafana (Go): affected all versions; no fix listed
- github.com/grafana/grafana (Go): affected from 8.0.0; fixed in 8.3.10
- github.com/grafana/grafana (Go): affected from 8.0.0; fixed in 8.3.10
- github.com/grafana/grafana (Go): affected from 8.4.0; fixed in 8.4.10
- github.com/grafana/grafana (Go): affected from 8.4.0; fixed in 8.4.10
- github.com/grafana/grafana (Go): affected from 8.5.0; fixed in 8.5.9
- github.com/grafana/grafana (Go): affected from 8.5.0; fixed in 8.5.9
- github.com/grafana/grafana (Go): affected from 9.0.0; fixed in 9.0.3
- github.com/grafana/grafana (Go): affected from 9.0.0; fixed in 9.0.3
- grafana (Bitnami): affected from 8.0.0; fixed in 8.3.10, 8.4.10, 8.5.9, 9.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31097/ (Markdown: https://insights.sbomify.com/CVE-2022-31097/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31097
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31097
- OSV: https://osv.dev/vulnerability/CVE-2022-31097

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31097/
Summaries are generated and may contain mistakes; the official description above is the record.
