{"answers":{"affected":"3 open source packages ship an affected version, including rulex. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-31100 in the wild and no public exploit code.","fix":"Upgrade rulex to 0.4.3 or later.","what":"CVE-2022-31100 is a medium-severity denial of service vulnerability in rulex-rs rulex, published on 27 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-31100 and fix it if it is affected.\n\nWhat it is: CVE-2022-31100 is a medium-severity denial of service vulnerability in rulex-rs rulex, published on 27 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-31100 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- rulex (crates.io): affected all versions; fixed in 0.4.3\n- rulex (crates.io): affected all versions; fixed in 0.4.3\n- rulex (crates.io): affected from 0.0.0-0; fixed in 0.4.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-31100/ (Markdown: https://insights.sbomify.com/CVE-2022-31100/index.md)","id":"CVE-2022-31100","markdown":"https://insights.sbomify.com/CVE-2022-31100/index.md","name":"CVE-2022-31100","record":{"aliases":["GHSA-8v9w-p43c-r885","RUSTSEC-2022-0031"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust regex library","requires_auth":"low_privilege","summary":"Attackers can cause a denial of service by providing crafted regular expressions that trigger a panic in the rulex library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"pomsky","vendor":"pomsky-lang"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-617","name":"Reachable Assertion"}],"description":"rulex is a new, portable, regular expression language. When parsing untrusted rulex expressions, rulex may crash, possibly enabling a Denial of Service attack. This happens when the expression contains a multi-byte UTF-8 code point in a string literal or after a backslash, because rulex tries to slice into the code point and panics as a result. This is a security concern for you, if your service parses untrusted rulex expressions (expressions provided by an untrusted user), and your service becomes unavailable when the thread running rulex panics. The crashes are fixed in version **0.4.3**. Affected users are advised to update to this version. The only known workaround for this issue is to assume that regular expression parsing will panic and to add logic to catch panics.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Reachable Assertion in rulex","id":"CVE-2022-31100","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":3,"n_references":2,"next":{"headline":"SQL Injection in prestashop/blockwishlist","id":"CVE-2022-31101"},"packages":[{"ecosystem":"crates.io","fixed":["0.4.3"],"introduced":["0"],"last_affected":[],"package":"rulex","purl":null,"source":"GHSA-8v9w-p43c-r885"},{"ecosystem":"crates.io","fixed":["0.4.3"],"introduced":["0"],"last_affected":[],"package":"rulex","purl":"pkg:cargo/rulex","source":"GHSA-8v9w-p43c-r885"},{"ecosystem":"crates.io","fixed":["0.4.3"],"introduced":["0.0.0-0"],"last_affected":[],"package":"rulex","purl":"pkg:cargo/rulex","source":"RUSTSEC-2022-0031"}],"prev":{"headline":"Uncontrolled Recursion in rulex","id":"CVE-2022-31099"},"products":["rulex"],"published":"2022-06-27","related":[{"cvss_score":6.5,"headline":"Uncontrolled Recursion in rulex","id":"CVE-2022-31099","kev_date_added":null,"published":"2022-06-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["rulex-rs"]},"summary":"Attackers can cause a denial of service by providing crafted regular expressions that trigger a panic in the rulex library.","url":"https://insights.sbomify.com/CVE-2022-31100/"}