CVE-2022-31101 SQL Injection in prestashop/blockwishlist

High 8.1 Published Updated

An authenticated customer can perform SQL injection in the PrestaShop blockwishlist extension, allowing unauthorized data access or modification.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-31101?

CVE-2022-31101 is a high-severity SQL injection vulnerability in PrestaShop blockwishlist, published on 27 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

prestashop/blockwishlist is a prestashop extension which adds a block containing the customer's wishlists. In affected versions an authenticated customer can perform SQL injection. This issue is fixed in version 2.1.1. Users are advised to upgrade. There are no known workarounds for this issue.

Weakness: CWE-89

Which versions are affected by CVE-2022-31101?

2 open source packages ship an affected version, including prestashop/blockwishlist. It affects 1 product.

PackageAffectedFixed in
prestashop/blockwishlist PackagistFrom 2.0.02.1.1
prestashop/blockwishlist PackagistFrom 2.0.02.1.1

Products include Prestashop Blockwishlist.

How do I fix CVE-2022-31101?

Upgrade prestashop/blockwishlist to 2.1.1 or later.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2022-31101 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31101 exists.

Public exploit code: 1 Exploit-DB entry, 1 Nuclei template and 2 proofs of concept on GitHub.

Sources

Also known as GHSA-2jx3-5j9v-prpp.

Is CVE-2022-31101 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free