{"answers":{"affected":"2 open source packages ship an affected version, including prestashop/blockwishlist. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31101 exists.","fix":"Upgrade prestashop/blockwishlist to 2.1.1 or later.","what":"CVE-2022-31101 is a high-severity SQL injection vulnerability in PrestaShop blockwishlist, published on 27 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-31101 and fix it if it is affected.\n\nWhat it is: CVE-2022-31101 is a high-severity SQL injection vulnerability in PrestaShop blockwishlist, published on 27 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31101 exists.\n\nAffected packages and fixed versions:\n- prestashop/blockwishlist (Packagist): affected from 2.0.0; fixed in 2.1.1\n- prestashop/blockwishlist (Packagist): affected from 2.0.0; fixed in 2.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-31101/ (Markdown: https://insights.sbomify.com/CVE-2022-31101/index.md)","id":"CVE-2022-31101","markdown":"https://insights.sbomify.com/CVE-2022-31101/index.md","name":"CVE-2022-31101","record":{"aliases":["GHSA-2jx3-5j9v-prpp"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"PrestaShop plugin","requires_auth":"low_privilege","summary":"An authenticated customer can perform SQL injection in the PrestaShop blockwishlist extension, allowing unauthorized data access or modification.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"blockwishlist","vendor":"prestashop"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"prestashop/blockwishlist is a prestashop extension which adds a block containing the customer's wishlists. In affected versions an authenticated customer can perform SQL injection. This issue is fixed in version 2.1.1. Users are advised to upgrade. There are no known workarounds for this issue.","ecosystems":["Packagist"],"exploits":{"exploitdb":1,"first_seen":"2022-07-24","github_poc":2,"max_poc_stars":42,"metasploit":0,"nuclei":1,"refs":[{"date":"2022-07-24T21:50:13Z","kind":"github_poc","ref":"https://github.com/MathiasReker/blmvuln","stars":42,"title":"Major Security Vulnerability on PrestaShop Websites - CVE-2022-31101"},{"date":"2022-08-09T10:29:48Z","kind":"github_poc","ref":"https://github.com/karthikuj/CVE-2022-31101","stars":25,"title":"Exploit for PrestaShop bockwishlist module 2.1.0 SQLi (CVE-2022-31101)"},{"date":"2022-08-09","kind":"exploitdb","ref":"51001","stars":null,"title":"Prestashop blockwishlist module 2.1.0 - SQLi"},{"date":null,"kind":"nuclei","ref":"http/cves/2022/CVE-2022-31101.yaml","stars":null,"title":"Prestashop Blockwishlist 2.1.0 SQL Injection"}],"tier":"weaponised"},"has_fix":true,"headline":"SQL Injection in prestashop/blockwishlist","id":"CVE-2022-31101","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"sql_injection","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"Cross-site Scripting for Argo CD single sign on users","id":"CVE-2022-31102"},"packages":[{"ecosystem":"Packagist","fixed":["2.1.1"],"introduced":["2.0.0"],"last_affected":[],"package":"prestashop/blockwishlist","purl":null,"source":"GHSA-2jx3-5j9v-prpp"},{"ecosystem":"Packagist","fixed":["2.1.1"],"introduced":["2.0.0"],"last_affected":[],"package":"prestashop/blockwishlist","purl":"pkg:composer/prestashop/blockwishlist","source":"GHSA-2jx3-5j9v-prpp"}],"prev":{"headline":"Reachable Assertion in rulex","id":"CVE-2022-31100"},"products":["blockwishlist"],"published":"2022-06-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-22","vendors":["PrestaShop"]},"summary":"An authenticated customer can perform SQL injection in the PrestaShop blockwishlist extension, allowing unauthorized data access or modification.","url":"https://insights.sbomify.com/CVE-2022-31101/"}