# CVE-2022-31101: SQL Injection in prestashop/blockwishlist

> An authenticated customer can perform SQL injection in the PrestaShop blockwishlist extension, allowing unauthorized data access or modification.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jun 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-2jx3-5j9v-prpp

## What is CVE-2022-31101?

CVE-2022-31101 is a high-severity SQL injection vulnerability in PrestaShop blockwishlist, published on 27 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

prestashop/blockwishlist is a prestashop extension which adds a block containing the customer's wishlists. In affected versions an authenticated customer can perform SQL injection. This issue is fixed in version 2.1.1. Users are advised to upgrade. There are no known workarounds for this issue.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2022-31101?

2 open source packages ship an affected version, including prestashop/blockwishlist. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `prestashop/blockwishlist` | Packagist | From 2.0.0 | 2.1.1 |
| `prestashop/blockwishlist` | Packagist | From 2.0.0 | 2.1.1 |

Products: Prestashop Blockwishlist.

## How do I fix CVE-2022-31101?

Upgrade prestashop/blockwishlist to 2.1.1 or later.

## Is CVE-2022-31101 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31101 exists.

Public exploit code:

- Major Security Vulnerability on PrestaShop Websites - CVE-2022-31101 (github_poc): https://github.com/MathiasReker/blmvuln
- Exploit for PrestaShop bockwishlist module 2.1.0 SQLi (CVE-2022-31101) (github_poc): https://github.com/karthikuj/CVE-2022-31101
- Prestashop blockwishlist module 2.1.0 - SQLi (exploitdb)
- Prestashop Blockwishlist 2.1.0 SQL Injection (nuclei): http/cves/2022/CVE-2022-31101.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31101 and fix it if it is affected.

What it is: CVE-2022-31101 is a high-severity SQL injection vulnerability in PrestaShop blockwishlist, published on 27 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31101 exists.

Affected packages and fixed versions:
- prestashop/blockwishlist (Packagist): affected from 2.0.0; fixed in 2.1.1
- prestashop/blockwishlist (Packagist): affected from 2.0.0; fixed in 2.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31101/ (Markdown: https://insights.sbomify.com/CVE-2022-31101/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31101
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31101
- OSV: https://osv.dev/vulnerability/CVE-2022-31101

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31101/
Summaries are generated and may contain mistakes; the official description above is the record.
