{"answers":{"affected":"2 open source packages ship an affected version, including lettersanitizer. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-31103 in the wild and no public exploit code.","fix":"Upgrade lettersanitizer to 1.0.2 or later.","what":"CVE-2022-31103 is a high-severity denial of service vulnerability in mat-sz lettersanitizer, published on 27 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-31103 and fix it if it is affected.\n\nWhat it is: CVE-2022-31103 is a high-severity denial of service vulnerability in mat-sz lettersanitizer, published on 27 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-31103 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- lettersanitizer (npm): affected all versions; fixed in 1.0.2\n- lettersanitizer (npm): affected all versions; fixed in 1.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-31103/ (Markdown: https://insights.sbomify.com/CVE-2022-31103/index.md)","id":"CVE-2022-31103","markdown":"https://insights.sbomify.com/CVE-2022-31103/index.md","name":"CVE-2022-31103","record":{"aliases":["GHSA-7r3r-gq8p-v9jj"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"npm HTML sanitizer","requires_auth":"none","summary":"Attackers can cause a denial of service in applications using lettersanitizer by sending emails with specific CSS at-rules.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"lettersanitizer","vendor":"lettersanitizer_project"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-754","name":"Improper Check for Unusual or Exceptional Conditions"}],"description":"lettersanitizer is a DOM-based HTML email sanitizer for in-browser email rendering. All versions of lettersanitizer below 1.0.2 are affected by a denial of service issue when processing a CSS at-rule `@keyframes`. This package is depended on by [react-letter](https://github.com/mat-sz/react-letter), therefore everyone using react-letter is also at risk. The problem has been patched in version 1.0.2.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper handling of CSS at-rules in lettersanitizer","id":"CVE-2022-31103","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"Miscompilation of `i8x16.swizzle` and `select` with v128 inputs in Wasmtime","id":"CVE-2022-31104"},"packages":[{"ecosystem":"npm","fixed":["1.0.2"],"introduced":["0"],"last_affected":[],"package":"lettersanitizer","purl":null,"source":"GHSA-7r3r-gq8p-v9jj"},{"ecosystem":"npm","fixed":["1.0.2"],"introduced":["0"],"last_affected":[],"package":"lettersanitizer","purl":"pkg:npm/lettersanitizer","source":"GHSA-7r3r-gq8p-v9jj"}],"prev":{"headline":"Cross-site Scripting for Argo CD single sign on users","id":"CVE-2022-31102"},"products":["lettersanitizer"],"published":"2022-06-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["mat-sz"]},"summary":"Attackers can cause a denial of service in applications using lettersanitizer by sending emails with specific CSS at-rules.","url":"https://insights.sbomify.com/CVE-2022-31103/"}