CVE-2022-31105 Argo CD's certificate verification is skipped for connections to OIDC providers
Attackers can bypass certificate validation for OIDC connections, allowing trust of malicious providers and potential account takeover in Argo CD.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-31105?
CVE-2022-31105 is a high-severity vulnerability in Argoproj Argo Cd, published on 12 Jul 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Argo CD is a declarative, GitOps continuous delivery tool for Kubernetes. Argo CD starting with version 0.4.0 and prior to 2.2.11, 2.3.6, and 2.4.5 is vulnerable to an improper certificate validation bug which could cause Argo CD to trust a malicious (or otherwise untrustworthy) OpenID Connect (OIDC) provider. A patch for this vulnerability has been released in Argo CD versions 2.4.5, 2.3.6, and 2.2.11. There are no complete workarounds, but a partial workaround is available. Those who use an external OIDC provider (not the bundled Dex instance), can mitigate the issue by setting the `oidc.config.rootCA` field in the `argocd-cm` ConfigMap. This mitigation only forces certificate validation when the API server handles login flows. It does not force certificate verification when verifying tokens on API calls.
Which versions are affected by CVE-2022-31105?
8 open source packages ship an affected version, including github.com/argoproj/argo-cd and github.com/argoproj/argo-cd/v2. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
github.com/argoproj/argo-cd Go | From 0.4.0 | None |
github.com/argoproj/argo-cd Go | From 0.4.0 | 2.2.11 |
github.com/argoproj/argo-cd Go | From 0.4.0 | 2.2.11 |
github.com/argoproj/argo-cd Go | From 2.3.0 | 2.3.6 |
github.com/argoproj/argo-cd Go | From 2.3.0 | 2.3.6 |
github.com/argoproj/argo-cd Go | From 2.4.0 | 2.4.5 |
2 more packages
github.com/argoproj/argo-cd Go | From 2.4.0 | 2.4.5 |
github.com/argoproj/argo-cd/v2 Go | All versions | 2.2.11, 2.3.6, 2.4.5 |
Products include Argoproj Argo Cd, Linuxfoundation Argo-Cd.
How do I fix CVE-2022-31105?
Upgrade github.com/argoproj/argo-cd to a fixed version for your release line: 2.2.11, 2.3.6 or 2.4.5.
Is CVE-2022-31105 being exploited?
There is no known exploitation of CVE-2022-31105 in the wild and no public exploit code.
Other vulnerabilities in Argoproj Argo Cd
- CVE-2025-55190 Argo CD: Project API Token Exposes Repository Credentials
- CVE-2022-29165 Argo CD will blindly trust JWT claims if anonymous access is enabled
- CVE-2023-40029 Cluster secret might leak in cluster details page in Argo CD
- CVE-2022-24768 Improper access control allows admin privilege escalation in Argo CD
- CVE-2024-21652 Argo CD vulnerable to Bypassing of Brute Force Protection via Application Crash and In-Memory Data Loss
Sources
Also known as GHSA-7943-82jg-wmw5, GO-2022-0518.