# CVE-2022-31105: Argo CD's certificate verification is skipped for connections to OIDC providers

> Attackers can bypass certificate validation for OIDC connections, allowing trust of malicious providers and potential account takeover in Argo CD.

- **Severity:** High 8.3 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Jul 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-7943-82jg-wmw5, GO-2022-0518

## What is CVE-2022-31105?

CVE-2022-31105 is a high-severity vulnerability in Argoproj Argo Cd, published on 12 Jul 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Argo CD is a declarative, GitOps continuous delivery tool for Kubernetes. Argo CD starting with version 0.4.0 and prior to 2.2.11, 2.3.6, and 2.4.5 is vulnerable to an improper certificate validation bug which could cause Argo CD to trust a malicious (or otherwise untrustworthy) OpenID Connect (OIDC) provider. A patch for this vulnerability has been released in Argo CD versions 2.4.5, 2.3.6, and 2.2.11. There are no complete workarounds, but a partial workaround is available. Those who use an external OIDC provider (not the bundled Dex instance), can mitigate the issue by setting the `oidc.config.rootCA` field in the `argocd-cm` ConfigMap. This mitigation only forces certificate validation when the API server handles login flows. It does not force certificate verification when verifying tokens on API calls.

Weakness: CWE-599 (Missing Validation of OpenSSL Certificate), CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2022-31105?

8 open source packages ship an affected version, including github.com/argoproj/argo-cd and github.com/argoproj/argo-cd/v2. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/argoproj/argo-cd` | Go | From 0.4.0 | None |
| `github.com/argoproj/argo-cd` | Go | From 0.4.0 | 2.2.11 |
| `github.com/argoproj/argo-cd` | Go | From 0.4.0 | 2.2.11 |
| `github.com/argoproj/argo-cd` | Go | From 2.3.0 | 2.3.6 |
| `github.com/argoproj/argo-cd` | Go | From 2.3.0 | 2.3.6 |
| `github.com/argoproj/argo-cd` | Go | From 2.4.0 | 2.4.5 |
| `github.com/argoproj/argo-cd` | Go | From 2.4.0 | 2.4.5 |
| `github.com/argoproj/argo-cd/v2` | Go | All versions | 2.2.11, 2.3.6, 2.4.5 |

Products: Argoproj Argo Cd, Linuxfoundation Argo-Cd.

## How do I fix CVE-2022-31105?

Upgrade github.com/argoproj/argo-cd to a fixed version for your release line: 2.2.11, 2.3.6 or 2.4.5.

## Is CVE-2022-31105 being exploited?

There is no known exploitation of CVE-2022-31105 in the wild and no public exploit code.

## Other vulnerabilities in Argoproj Argo Cd

- [CVE-2025-55190](https://insights.sbomify.com/CVE-2025-55190/): Argo CD: Project API Token Exposes Repository Credentials (critical 10.0)
- [CVE-2022-29165](https://insights.sbomify.com/CVE-2022-29165/): Argo CD will blindly trust JWT claims if anonymous access is enabled (critical 10.0)
- [CVE-2023-40029](https://insights.sbomify.com/CVE-2023-40029/): Cluster secret might leak in cluster details page in Argo CD (critical 9.9)
- [CVE-2022-24768](https://insights.sbomify.com/CVE-2022-24768/): Improper access control allows admin privilege escalation in Argo CD (critical 9.9)
- [CVE-2024-21652](https://insights.sbomify.com/CVE-2024-21652/): Argo CD vulnerable to Bypassing of Brute Force Protection via Application Crash and In-Memory Data Loss (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31105 and fix it if it is affected.

What it is: CVE-2022-31105 is a high-severity vulnerability in Argoproj Argo Cd, published on 12 Jul 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-31105 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/argoproj/argo-cd (Go): affected from 0.4.0; no fix listed
- github.com/argoproj/argo-cd (Go): affected from 0.4.0; fixed in 2.2.11
- github.com/argoproj/argo-cd (Go): affected from 0.4.0; fixed in 2.2.11
- github.com/argoproj/argo-cd (Go): affected from 2.3.0; fixed in 2.3.6
- github.com/argoproj/argo-cd (Go): affected from 2.3.0; fixed in 2.3.6
- github.com/argoproj/argo-cd (Go): affected from 2.4.0; fixed in 2.4.5
- github.com/argoproj/argo-cd (Go): affected from 2.4.0; fixed in 2.4.5
- github.com/argoproj/argo-cd/v2 (Go): affected all versions; fixed in 2.2.11, 2.3.6, 2.4.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31105/ (Markdown: https://insights.sbomify.com/CVE-2022-31105/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31105
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31105
- OSV: https://osv.dev/vulnerability/CVE-2022-31105

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31105/
Summaries are generated and may contain mistakes; the official description above is the record.
