{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31106 exists.","fix":"No fix has been published for CVE-2022-31106 yet. Limit exposure of the affected software until one is available.","what":"CVE-2022-31106 is a high-severity unsafe deserialization vulnerability in Clever underscore.deep, published on 28 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-31106 and fix it if it is affected.\n\nWhat it is: CVE-2022-31106 is a high-severity unsafe deserialization vulnerability in Clever underscore.deep, published on 28 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31106 exists.\n\nAffected product: Clever underscore.deep. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-31106/ (Markdown: https://insights.sbomify.com/CVE-2022-31106/index.md)","id":"CVE-2022-31106","markdown":"https://insights.sbomify.com/CVE-2022-31106/index.md","name":"CVE-2022-31106","record":{"aliases":["GHSA-8j79-hfj5-f2xm"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript utility library","requires_auth":"none","summary":"Prototype pollution in underscore.deep allows attackers to modify object prototypes via crafted payloads, potentially leading to code execution or privilege escalation.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"underscore.deep","vendor":"clever"}],"cvss":{"score":8.3,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-915","name":"Improperly Controlled Modification of Dynamically-Determined Object Attributes"},{"id":"CWE-1321","name":"Improperly Controlled Modification of Object Prototype Attributes"}],"description":"Underscore.deep is a collection of Underscore mixins that operate on nested objects. Versions of `underscore.deep` prior to version 0.5.3 are vulnerable to a prototype pollution vulnerability. An attacker can craft a malicious payload and pass it to `deepFromFlat`, which would pollute any future Objects created. Any users that have `deepFromFlat` or `deepPick` (due to its dependency on `deepFromFlat`) in their code should upgrade to version 0.5.3 as soon as possible. Users unable to upgrade may mitigate this issue by modifying `deepFromFlat` to prevent specific keywords which will prevent this from happening.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"Prototype Pollution in underscore.deep","id":"CVE-2022-31106","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"deserialization","year":"2022"},"n_packages":0,"n_references":2,"next":{"headline":"Grafana account takeover via OAuth vulnerability","id":"CVE-2022-31107"},"packages":[],"prev":{"headline":"Argo CD's certificate verification is skipped for connections to OIDC providers","id":"CVE-2022-31105"},"products":["underscore.deep"],"published":"2022-06-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-22","vendors":["Clever"]},"summary":"Prototype pollution in underscore.deep allows attackers to modify object prototypes via crafted payloads, potentially leading to code execution or privilege escalation.","url":"https://insights.sbomify.com/CVE-2022-31106/"}