# CVE-2022-31106: Prototype Pollution in underscore.deep

> Prototype pollution in underscore.deep allows attackers to modify object prototypes via crafted payloads, potentially leading to code execution or privilege escalation.

- **Severity:** High 8.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 28 Jun 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-8j79-hfj5-f2xm

## What is CVE-2022-31106?

CVE-2022-31106 is a high-severity unsafe deserialization vulnerability in Clever underscore.deep, published on 28 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Underscore.deep is a collection of Underscore mixins that operate on nested objects. Versions of `underscore.deep` prior to version 0.5.3 are vulnerable to a prototype pollution vulnerability. An attacker can craft a malicious payload and pass it to `deepFromFlat`, which would pollute any future Objects created. Any users that have `deepFromFlat` or `deepPick` (due to its dependency on `deepFromFlat`) in their code should upgrade to version 0.5.3 as soon as possible. Users unable to upgrade may mitigate this issue by modifying `deepFromFlat` to prevent specific keywords which will prevent this from happening.

Weakness: CWE-915 (Improperly Controlled Modification of Dynamically-Determined Object Attributes), CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2022-31106?

It affects 1 product.


Products: Clever Underscore.deep.

## How do I fix CVE-2022-31106?

No fix has been published for CVE-2022-31106 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-31106 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31106 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31106 and fix it if it is affected.

What it is: CVE-2022-31106 is a high-severity unsafe deserialization vulnerability in Clever underscore.deep, published on 28 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31106 exists.

Affected product: Clever underscore.deep. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31106/ (Markdown: https://insights.sbomify.com/CVE-2022-31106/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31106
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31106
- OSV: https://osv.dev/vulnerability/CVE-2022-31106

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31106/
Summaries are generated and may contain mistakes; the official description above is the record.
